Terminal within Eclipse not connecting to localhost

I want to connect to my local terminal via Eclipse in Windows. I am able to connect to the server but not my own machine. It opens from "cube icon" -> Terminal but I want to open and connect to it in Eclipse.

How should I connect to it?

  • 0
  • 0
  • 68
  • 2
  • 2

Answers

After selecting the Terminal tab (like you have done in the picture), you can click on the "Open a Terminal" button on the right side of the bar that contains the tabs. This will open a "Launch Terminal" popup. Mine defaults to "Telnet Terminal" for "Choose terminal". In here, I normally just type "localhost" into the "Host" field and leave the rest of the default values. After clicking OK, I am connected to my instance.

Note: Make sure %Service_Telnet is enabled

After changing %Service_Telnet to "enabled" this worked.

%Service_Telnet can be found from: management portal -> system administration -> security -> services

Looks like you've got this figured out, but I wanted to add another option - using the Local Terminal option in the plugin to connect to a Caché/Ensemble/HealthShare/InterSystems IRIS instance:

  1. After installing the Terminal plugin open the Terminal view (Window > Show View > Other > Terminal > Terminal)
  2. Select the "Open a Terminal" toolbar button  from the view
  3. Select "Local Terminal" from the "Choose terminal:" drop down menu                                                                                                                                                                    ​​​​​​​
  4. If csession isn't in your PATH, navigate to your instance's bin directory - example: cd C:\InterSystems\Cache\bin
  5. Launch a Caché terminal session - example: csession Cache

Comments

Hi, Lassi!

Just in case you've never heard about but there is a community supported WebTerminal which works via web-sockets and supports code highlighting, code completion and many other convenient things. And it doesn't need terminal access (telnet, ssh) to a server, web access is enough.