Terminal can not be connected.

■Setting up CACHÉ preferred connection server.
server name:localhost
ip adress:127.0.0.1
port:1972
Telnetport:23
web server port:57772
web server ip adress:
CSP server instance:
comment:
Authentication method=>password

■hosts
localhost 127.0.0.1

■os
windows10 (virtual box)

■>ifconfig
windows IP configuration
Ethernet adapter Ethernet:
Connection-specific DNS suffix:
Link local IPv6 address: fe80 :: b943: 6646: 21a8: 1a5b% 2
IPv4 address: 10.0.2.15
Subnet mask: 255.255.255.0
Default gateway: 10.0.2.2

■>ping 127.0.0.1
Number of packets: transmission = 4, reception = 4, loss = 0 (0% loss)

■>netstat -an
127.0.0.1:1900 :
127.0.0.1:55152 :
127.0.0.1:57967 :

nets winhttp>show proxy
Current WinHTTP proxy settings:
Direct access(no proxy server)

If you enter the preferred connection server as above and click on the cube and make it to remote system access → terminal → localhost,

TCP connect () failed - exception satisfied select (), Reason: (10061, 0x274 d) The connection could not be made because it was rejected by the target computer.

It will be displayed.

Is the way of setting wrong?

It would be greatly appreciated if you could tell us what you can fix and you will be able to use the terminal.

Thanking you in advance.

  • 0
  • 0
  • 274
  • 4
  • 1

Answers

The main cause of the problem is that you are not connecting to Terminal but Telnet.

If you connect to defined Server connection which name is different then the installed instance for given Cube, it starts Telnet and not Terminal - you can see it from the name of the window. Name for Terminal is  TRM:<process id> (<instance name>) while for Telnet the name is <IP address> - Caché Telnet.

For Windows systems you need to enable Telnet on port 23 (as defined by your Caché Server Manager) to be able to connect.

To enable Telnet you need to open Management Portal and go to System Administration > Security > Services > %Service Telnet, check the Enabled checkbox and save.

To change the Telnet port from default 23 you go to Management Portal > System Administration > Configuration > Device Settings > Telnet Settings.

Comments

Akio, what is the reason to use telnet? It is not very safe.  Why not use ssh?

It is not telnet, it does not know how to connect to ssh.