Question
Donald Bugbee · Sep 15, 2017

PROTECT error when opening a command pipe

Hi all.

I have been using  a command pipe to open/run UNIX scripts for months without issue.  We recently installed the 2016 Caché Upgrade and now I'm getting the following error when opening the pipe:

<PROTECT> *OPEN[Q](|CPIPE|)

I assume some security or permission setting is to blame, but I'm not sure exactly what.  Here's the snippet of code...

s cpipename="|CPIPE|"
s filepath="/path/script"
​o cpipename:(filepath:"R"):10

Any feedback would be greatly appreciated!

0
0 475
Discussion (4)1
Log in or sign up to continue

Donald, please set the checkmark against Ray's answer. This gives him credit and also marks your question as answered, so it no longer lists in DC as "unanswered".

Yep, that's the one.  Thanks Ray!