· Nov 30, 2023

Production allowed ports

Hi Guys,

Do we need to configure something in ports so that we can use it in a production?

I've a production with 8 running services and recently added a new service with new port but unable to get it working  

raising error 404.

When using an existing port that is used by current running service, my new service works fine but not when using a new port, I've added the new port to inbound rules in the firewall bit still no luck, so is there something I need to do to in Ensemble ?



Product version: Ensemble 2018.1
Discussion (3)3
Log in or sign up to continue

Hi Rochdi,

you provide very few details about you environment, some can be guessed.

You talk about using a services in a production and error 404, so I guess you have a business service using a SOAP inbound adapter or an HTTP inbound adapter and using a local port instead of the web server (Standard request is not enabled).

Since you do get a response (404 error is a response) when using that specific port, then the server is responding and your service works correctly with a different port, then a possibility is that that port you want to use is altready used by another HTTP/SOAP service.
If so, then when your business service starts you can check the Event Log and you probably find an error rhat th port cannot be opened.
You can also check that if you don't start your business service you still get 404 error.

But...this are only guesses, please provide more details.