Roger de Coninck · Sep 26, 2018

Open class file shows multiple times java.lang.NullPointer exception


Atelier 1.2 as well 1.3 throws java.lang.NullPointerException when opening a class file.

Never mind how to open the class file,  1) witin project explorer 2) atelier explorer 3) open resources  4) switcing between tabs (open files) etc..., I get these errors every time.

Never seen this problem in Atelier 1.1.

Do I miss something within the Eclipse environment? 

Does anyone has the same problem?

Best Regards,

Roger de Coninck.

0 638
Discussion (5)2
Log in or sign up to continue

What version of Eclipse are you using? We've seen similar issues with Atelier 1.3.117 on versions of Eclipse besides Photon.

I would suggest that you start by installing a new Eclipse Photon client then install the Atelier plug-in.

Hello Nicole,

For Atelier 1.3 I use the Eclipse Photon Version: 2018-09 (4.9.0) Build id: 20180917-1800.

For Atelier 1.2 I used Eclipse IDE for Java Developers Version: Oxygen.2 Release (4.7.2)
Build id: 20171218-0600

For Atelier 1.1 used the same Eclipse version as 1.2. This without this problem.

Best Regards


Hi Roger.

Please notice Eclipse 2018-09 (4.9.0) is not Photon. It seems that it's codename is SimRel (

Eclipse Photon is 4.8.

Please try to use Atelier 1.3 on top of Eclipse Photon 4.8.

Thank you,

Hello Alexander,

I have installed Eclipse Photon 4.8 and the problem is solved.,

Thanks for that.

Still not clear why Atelier 1.2 on the correct eclipse version has that  problem.

Best Regards