Question
Eduard Lebedyuk · Jun 7, 2018

Localize DeepSee time dimension

I have a server with rusw locale but in my cube the time dimension shows dates such as "JAN-2018". Is there a way to either localize that (preferably) or just output numbers  like "01-2018"?

Architect:

Analyzer:

Also in architect, in level settings there is a "Time Format" property, what's that? Tried setting it to 3 but it didn't help.

 

0
0 313
Discussion (5)0
Log in or sign up to continue

%DeepSee.Utils:%FormatDate offers this options

Format a date value (in $H format) according to the format in pFormat. The format string can contain:

  • "y" - Year number (4 digits).
  • "q" - Quarter number.
  • "m" - Month number, with no leading zero.
  • "mm" - Month number, with leading zero.
  • "mmm" - Short name of month (using server locale).
  • "mmmm" - Long name of month (using server locale).
  • "d" - Day number, with no leading zero.
  • "dd" - Day number, with leading zero.
  • "ddd" - Short name of day (using server locale).
  • "dddd" - Long name of day (using server locale).
  • "\x" - display character "x"
  • " " - space
  • "/" - "/"
  • "-" - "-"
  • "." - "."

Added mm as Time Format and rebuilt cube. Got 01 instead of JAN.

Removed mm. Turns out, all you need to do is to use locale defaults in Locale Settings

What's the advantage over Use Locale Defaults solution?

Hi, Ed!

You can build your own Localised dimension via expressions and put whatever language you want for the months.

No advantage of course if Locale Defaults works for you. That was not obvious. Does it work?

Yes. I set use locale defaults  to true and rebuilt the cube. After that Analyzer started showing localized date values.