Question
Ben Rebecca · Sep 20

IRIS minimal install but not appearing in system tray

I've installed the latest version of IRIS using Minimal settings as I'm just looking for some basic IDE without connecting to anything.

After install, I see all the files in the Intersystems folder, however there is no "IR" in the system tray. I don't see any executables to launch either. System restart did not populate the system tray either.

Is there any other way to launch Studio?

Product version: IRIS 2022.1
0
0 77
Discussion (9)1
Log in or sign up to continue

Hi Vic,

Thank you for letting me know what was supposed to be in Bin. It was populated, but not with an .exe.   I reinstalled with higher permissions and that looks to have populated the .exe and the system tray.

However now I have a new problem. Studio is grayed out on the IR tray launch. Pulling up the executable, the "Sever Connection" window appears, but I do not have the option to select "USER" in the name space. As such it's prompting me to actually connect to a server. The only option I have available is local host. Is there a step I'm missing to just be able to create local scripts and not connect to a server?

Ah I think I missed that part of your initial question. Studio isn't like other IDEs where it will save to a workspace on the filesystem, Studio writes to the IRIS database hence why it's asking you to connect to a (running) instance. That's why the icon is grey I assume, because you're not running IRIS. Since you said you installed IRIS and not just Studio I'm assuming you do have that IRIS instance available, but I don't know if Studio matches what you are looking for exactly - a barebones IDE that doesn't need to connect to anything.

I recall on a previous install some time ago there was an ability to create scripts locally by loading up studio and selecting "USER." This allowed to not have any server connectivity and to just run scripts locally for learning/experimenting. Is that function no longer available?

I appreciate your responses so far - thank you!

How long ago is "some time ago"? I can't speak to forever but for at least the past several years I think it has worked this way. Is there a reason you don't want to connect to IRIS? What scripts are you trying to run?

I would think the community edition of IRIS which is presumably what you are using should do just fine for learning/experimenting.

Within a year. Was able to find a screenshot of how a previous install appeared. 

I believe I did install the community version of IRIS (apologies if I misspoke). Here's the install file: IRIS_Community-2022.1.0.209.0-win_x64 

edit: to answer the second part — I'm just looking to write and learn MUMPS/cache locally without any server connection.

I don't know if the picture is still uploading, but I can't see it. The fact you got prompted for USER implies to me that you had an existing connection to IRIS (likely with username/password autosaved) and that's why you immediately got to the namespace prompt. 

When you install the community edition you get Studio and the server locally - so I'm not sure what the downside of connecting to that server is, unless I'm missing something.

Likely just a profound misunderstanding of the set up portion on my part. I'm not familiar with having to set up a server for an IDE.

To start server services, I'm using the irisstart in bin. I receive the prompt of:

"usage:

irisstart <InstantName>

  to start instance <InstanceName>"

I've tried using the default login of _system  and SYS (or sys) per the documentation but get a communication error.

I might suggest you get the server running and verify that it is happy before trying to get in with Studio. It might be easiest to do it all from the cube - ie you can start iris from there. I mention that because I don't believe you're expected to call irisstart directly. You can call "iris start <instancename>" (distinction is using the iris command to call start).

If the cube fails to start IRIS it should throw an error (likely in the messages.log that the error will tell you to check).

Once you've started IRIS perhaps you can try accessing terminal and the management portal, then Studio. That could narrow down the communication error which may be generic.