Intersystems Caché Unicode and telnet-access

Hello,

We're having troubles with working over Telnet on Caché Unicode with WRQ Reflection.

We can't input extended characters (é,à,Ø,...), DELETE-key doesn't work, ...

Has anyone a solution for working with WRQ Reflection or a decent alternative ?

We tried Putty and Caché-terminal but these are not sufficent.

 

Regards,

Kurt Hofman.

  • 0
  • 0
  • 162
  • 2
  • 2

Answers

The main thing I can suggest is to verify that the client and server agree on the encoding. It's been years since I've used Reflection; hopefully it supports UTF-8. Check your settings and/or documentation.

When you're in a Caché session, look at the value of the $zmode special variable:

USER>w $zm
RY\Latin1\K\UTF8\

I'm not sure offhand what determines the default I/O translation table for a terminal, but if you see "RAW" instead of "UTF8", you can set it manually:

USER>u 0:(/IOT="UTF8")

USER>w $zm
RY\Latin1\K\UTF8\

$zm = RY\Latin1\K\UTF-8\

Reflection can show unicode's just fine, it's just that we can't input them !

Hi Kurt,

Some old terminal emulators cannot work with UTF8.

I used AniTa which had the same problem connecting to a Caché Unicode server.

I tried TeraTerm which is free and can at least work with UTF8 and VT320 emulation, but i haven't tried all our terminal tricks yet to see if it can do the job for 100%.

Once you start TeraTerm, don't forget to change in Setup->General the language to UTF-8,.

Setup -> Save Setup will save all your changes to a Teraterm.ini file so they will be in effect the next time.

 

 

Doesn't seem to work at all, ...

The only thing that works is Caché Terminal, but soms F-keys don't work and our customer don't like it :-(