Question
Jefferson Borges · Jul 21

Installing IRISHealth_Community-2022.1.0.209.0-lnxubuntu2004x64 on Ubuntu 20.04 LTS on oracle virtual box

Good morning. Perhaps someone can tell me if this IRIS health communit version (IRISHealth_Community-2022.1.0.209.0-lnxubuntu2004x64) is supposed

to work in an Ubuntu 20.04 LTS installation in an Oracle Virtual Box .

 

I am trying to install different versions on Ubuntu . I tried with the 18 version. No luck. Than I've tried with the 20.04 version. No luck either.

The error I am having now is below

///////////////////////// error message from the install ////////////////////////////////

home/epic/epicinstall/IRISHealth_Community-2022.1.0.209.0-lnxubuntu2004x64# ./irisinstall

Warning: The installer can't find a platform in this distribution

supported by your system.

Searching for platforms that might install in unsupported mode...

     1) Ubuntu LTS (x64)

Enter the number for your system:  1

Your system type is 'Ubuntu LTS (x64)'.

openssl version 1.1.1 is required.

** Installation aborted **

No packages will be installed.

//////////////////////////////////////////////////////////////// my comments now ////////////////////////////////////////

But there is an openssl version installed on the box.

Version 3 is installed

 

/////////// output from command  openssl version -a ////////////////////////////////

OpenSSL 3.0.2 15 Mar 2022 (Library: OpenSSL 3.0.2 15 Mar 2022)

built on: Mon Jul  4 11:20:23 2022 UTC

platform: debian-amd64

options:  bn(64,64)

compiler: gcc -fPIC -pthread -m64 -Wa,--noexecstack -Wall -Wa,--noexecstack -g -O2 -ffile-prefix-map=/build/openssl-Q8dQt3/openssl-3.0.2=. -flto=auto -ffat-lto-objects -flto=auto -ffat-lto-objects -fstack-protector-strong -Wformat -Werror=format-security -DOPENSSL_TLS_SECURITY_LEVEL=2 -DOPENSSL_USE_NODELETE -DL_ENDIAN -DOPENSSL_PIC -DOPENSSL_BUILDING_OPENSSL -DNDEBUG -Wdate-time -D_FORTIFY_SOURCE=2

OPENSSLDIR: "/usr/lib/ssl"

ENGINESDIR: "/usr/lib/x86_64-linux-gnu/engines-3"

MODULESDIR: "/usr/lib/x86_64-linux-gnu/ossl-modules"

Seeding source: os-specific

CPUINFO: OPENSSL_ia32cap=0xdefa220b478bffff:0x842421

////////////////  my comments ///////////////////////////

Well,  than I tried to install the version openssl 1.1.1  in this Ubuntu 20.04 but I am having compilations errors .

But before I proceed on the debug I thought I could ask if this IRIS community version is supposed to work in a virtual environement , like Oracle Virtual Box.

Maybe I amn just wasting my time....

Thank you very much for any input someone may send me.

Appreciate very much.

Jeff Borges

Product version: IRIS 2022.1
0
0 83
Discussion (3)2
Log in or sign up to continue

Not sure why yours is showing OpenSSL v3. I'm running IRIS for Health 2022.1.0.209.0 on a Ubuntu 20.04.4 LTS (GNU/Linux 5.4.0-121-generic x86_64) physical host and I had no issues with installation.

My guess is that it isn't really complaining about openssl, but that libssl isn't at least version 1.1.1.

I'd try running (as root):

# apt install openssl
# apt install libssl1.1

These commands should install pre-compiled binaries. The first one should automatically install openssl 1.1.1f and the 2nd the same version of the libssl libraries.

And yes, while I haven't specifically used VirtualBox, I am a long-time user of VMWare on multiple platforms, with multiple Linux guests and versions of Caché/IRIS. Virtualization has, so far, very rarely been an issue.

Thank you very much for your answer and taking the time to write.

Unfortunately it did not solve it.

When I run apt to install openssl it says the system is already at the latest level which is the version 3.

I tried to install the libssl1.1 but it does not find it among the packages available.

Maybe it is a problem with the new openssl version 3 and IRIS Health Community.

I don't know .

It is taking so much time on this that I think I will simply try the on line lab.

Perhaps some fix in the future for this install.

But Thank you again for the help and hope you have a nice end of  day