Installing Atelier with a different version of Eclipse

Is there a way to install just the Atelier plug-in to use in JBoss 8.1 or MyEclispe 2.5?

  • + 2
  • 0
  • 556
  • 5
  • 2

Answers

The Atelier plugin is targeted specifically at Eclipse and leverages significant Eclipse specific infrastructure such as the dynamic languages toolkit (DLTK). Unless JBOSS and/or MyEclipse are 100% compatible with Eclipse then the answer would be no. We have no plans to support any other IDE at this moment in time.

Hi David,

Good news! You can now install the Atelier plug-in in MyEclipse 2016 CI 4. Please try the following steps.

If you see some keybinding conflicts warning in the error log, you can resolve that within the IDE user preferences. Let me know if you have any questions.

Best,
Joyce

Joyce;

   Thanks, this works fine for that version. However we don't have that version available yet. We are using MyEclipse Pro 2015 v2.0 (from Genuitec). When I attempt to load the plug-in on this version, it fails loading the IDE piece with the error below. Any suggestions on how to correct this?

Cannot complete the install because one or more required items could not be found.
  Software being installed: Atelier IDE 1.0.190 (com.intersys.eclipse.feature.estudio.feature.group 1.0.190)
  Missing requirement: RCPTT support plugin 1.0.190 (com.intersys.eclipse.ui.rcptt 1.0.190) requires 'bundle org.eclipse.rcptt.ecl.core 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: Atelier IDE 1.0.190 (com.intersys.eclipse.feature.estudio.feature.group 1.0.190)
    To: com.intersys.eclipse.ui.rcptt [1.0.190]

Thanks for trying this out, David. We haven't tested MyEclipse Pro 2015 v2.0, so we need do some investigation. I will keep you updated.

- Joyce

David, could you post the full error message here? If there's a "Details" button, try click it and view the full error tree.

- Joyce

Here is everything that is available in the Details section:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Atelier IDE 1.0.190 (com.intersys.eclipse.feature.estudio.feature.group 1.0.190)
  Missing requirement: RCPTT support plugin 1.0.190 (com.intersys.eclipse.ui.rcptt 1.0.190) requires 'bundle org.eclipse.rcptt.ecl.core 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: Atelier IDE 1.0.190 (com.intersys.eclipse.feature.estudio.feature.group 1.0.190)
    To: com.intersys.eclipse.ui.rcptt [1.0.190]

David, please check whether the Eclipse Mars repository is in the list of your active update sites. If not, please add it and install Atelier again. Let me know if it works.

- Joyce