Question
Michael Lindner · Sep 2

Can't use terminal?

New to IRIS. Installed docker container as per instructions. From my system I run:

# docker exec -it iris bash

and then try to start a terminal session, which fails

irisowner@2f54ebfbc52f:~$ irissession IRIS

<NOTOPEN>

How do I successfully start a terminal session?

Product version: IRIS 2021.1
$ZV: IRIS for UNIX (Ubuntu Server LTS for x86-64 Containers) 2021.1 (Build 215U) Wed Jun 9 2021 12:37:06 EDT
00
1 0 7 124
Log in or sign up to continue

Try adding a space between iris and session

Thanks, but no and no

irisowner@2f54ebfbc52f:~$ iris session IRIS 

<NOTOPEN>

 

irisowner@2f54ebfbc52f:~$ iris terminal IRIS 

<NOTOPEN>

Which version of docker are you using? I had such a problem when I started using docker 1.13 on Red Hat Linux. Things worked for me after I got on Docker 19 or 20

Docker version 1.13.1, build 7d71120/1.13.1

running on

CentOS Linux release 7.9.2009 (Core)

In my experience, this version of docker did not work properly with IRIS. Can you try to get on current Docker version?

1.31 is the latest docker available for CentOS 7 from centos repos. I added the docker-ce repo, removed docker and reinstalled the latest docker-ce. That solved the problem. Thanks for you help!