· Aug 9, 2018

Atelier1.2 Not Found. Check the web server configurations.

I am having trouble configuring the environment in eclipse have download eclipse  for java script and web developers  followed the video but could not connect to the server I have my Apache server 7.0 added to the java environment and I can start and stop the server through eclipse IDE but when I fire atelier and add server I get the above error any help please .This is the first time I am trying to use the plug in through eclipse .Just in case There is another installation I need to do please advice but I am guessing something to do with atelier not seeing my configurations or permissions I am working on my machine please advice if there are permissions I need to grant

Discussion (7)2
Log in or sign up to continue

@John Murray

I might be connecting to a wrong server here is how I am doing my configuration for atelier:

  • Downloaded: Eclipse for javascript developers,Apache tomCat server 7.0
  • I installed the above configured my tomcat server to Listen at port 8080 
  • I then went to window--> preference-->Server and added my TomCat Server to eclipse run time Environment
  • On eclipse Market Place downloaded Atelier restarted eclipse after install and went on to Help-->Install new Software and added the Repository
  • Restarted eclipse went on to project-->other-->Atelier-->Server and tried to do the above as per your picture and nothing just that error message In case I missing out on something please advice.I have also noticed this when I start my server within eclipse or on the system and try to connect I get the above error but when I switch them off and try to connect i get Timeout error. That's one server at a time

I'm not clear what Tomcat has to do with your attempts to use Atelier. Atelier connects to Cache / Ensemble / HealthShare / IRIS servers, typically via the same webserver you use when managing those servers through InterSystems' Management Portal. This could be the private Apache instance that InterSystems installs by default, and which by default runs on port 57772.

Be sure that:

  1. The Caché/Ensemble/HealthShare/InterSystems IRIS instance that you are trying to connect to is version 2016.2+.
  2. Your web server (listening on the web port that you provide in the Server Connection Configuration dialog) is configured to handle requests starting with /api/atelier. The Atelier documentation explains how to do this for an IIS web server here, but the same principle applies to all web servers. Atelier makes REST requests to communicate with the server and those will start with /api/atelier instead of /csp like many other CSP requests.
  3. The /api/atelier web application is enabled at the Caché level. To do this:
    1. Launch the System Management Portal and select System Administration > Security > Applications > Web Applications
    2. Select the /api/atelier application
    3. Check the Enabled boxes for Application and CSP/ZEN and Save

If you are still having trouble I would suggest reaching out to InterSystems Support (email or call +1 617-621-0700).