Atelier connection broken error

Hi, every time I launch Atelier for the first time after my PC boot, it reports an error when trying to connect to a server.

Restarting Eclipse solves the issue and it no more manifests until next PC reboot.

Does anyone know how to avoid this issue? I run Windows 10, Java JRE 8

  • 0
  • 1
  • 220
  • 5
  • 2

Answers

Hi Dan.

There were three questions for error with RuntimeDelegateImpl. Have you looked there? Maybe they have some solutions for your question

https://community.intersystems.com/search?search=Runtimedelegateimpl

Thank you Alexander,

I tried to search community for this error but apparently I did not use correct keywords as I could not find previous posts with this very problem.

At least we have a workaround as explained in links you provided.

Dan

Actually, advices given in other answer are quitec contradicting, one says install glassfish whilst other says uninstall glassfish.

Why is Atelier at all trying to use glassfish?

Dan,

also try to put following lines in /configuration/config.ini

osgi.module.lock.timeout=600
equinox.statechange.timeout=600

Interesting! I've been suffering from the same problem, so I've just added those two lines in the hope they're a solution. Time will tell...

Started having the glassfish issue again (macbook pro). Adding these 2 lines to the config.ini fixed it for me. 

btw, On the mac you have to open the folder containing eclipse then right click and select "Show Package Contents" to see the /Contents/Eclipse/configuration/config.ini