Robert is correct that you need to install the terminal plugin. I would recommend using the most recent version which is available from the Eclipse release update site associated with the version of Eclipse you have installed.

If you are using Oxygen, then go to http://download.eclipse.org/releases/oxygen.

You can find product documentation on the topic from Atelier as well. Go to Help > Help Contents > InterSystems Atelier User Guide > Tasks > Installing the Eclipse Terminal Plug-in.

Based on Kenneth's comment, it seems the problem is fixed in the 1.1 beta release. If this doesn't work for you, I recommend contacting support.

Hello, Jan. It seems you are having a problem with the Java class loader. The team responsible for the Java Gateway forwarded the following suggestion. Could you please give it a try? If it doesn't help, please contact the WRC for further support.

java.lang.NoClassDefFoundError: Could not initialize class com.tieto.dataLake.content.data.Content_Data_Record is a Java class loader error typically means that the class loader ran into an exception when trying to load (read) the class. To make sure this is not a user error, I would suggest they try to write a small Java program that simply loads the above class (use Class.forName()), they might get the same error. If not, then it’s probably something to do with the static initializer, I imagine there must be one. They should try to catch an exception in it and that should provide more info on the actual error. A good example of what can go wrong is that they might try to access the file system, right there in the static initializer, and that the path or permissions are different in their dev environment, and on the machine where they try to import the class using the Java Gateway.

 

To avoid these kinds of errors, we have been advocating the use of a so called ‘façade approach’, where the user makes sure to build most of the app on the Java side, hiding all sorts of things like massive dependencies, big jar files, file system dependencies etc. etc. and exposing only that small app to Cache/Ensemble via the JG

Which version of Atelier were you using before? Did you install it to an Eclipse instance using the update site or were you using the 1.0 standalone application?

Atelier 1.0 does not provide a way to customize the color used for JavaScript code in CSP files. I recommend installing the Web Tools Platform (WTP) HTML editor which provides some JavaScript support. You can install it from the Eclipse release update site along with other web development related editors that you may find useful.  http://download.eclipse.org/releases/neon

WTP HTML Editor

You can find instructions in the product documentation to make this editor your default when opening CSP files. Go to Help > Help Contents > InterSystems Atelier User Guide > Tasks Editing HTML in CSP Files.

If you are interesting in upgrading to the Atelier 1.1 beta, you will see that your JavaScript code will no longer be colored green when opened in the Atelier Web Editor.

Atelier Web Editor

These menu items are context enabled, so you should have an Atelier editor open or have a file selected from the Atelier Explorer view. I suspect that the selection context wasn't an Atelier "element", so the menus were disabled.

The Server Explorer view from the Atelier perspective provides a shortcut to the Management Portal.

  1. Open the Server Explorer view
  2. Right-click on the connection you are interested in
  3. Select "Management Portal" from the context menu

The Management Portal will be opened in an external browser.

Hi, Mike. That error is referring to your file path. I recommend you contact the WRC with these sorts of problems as they will be able to quickly solve the problem.