Finally reason was that server's time zone was UTC. After changing it to correct one Ensemble shows times in local time.

Practically this lead us to the answer: erver's time was UTC. After changing server's timezone Ensemble shows local time.

but when these times are displayed in the Message Viewer they go through conversion and are displayed in local time

My problem is that they are displayed in UTC time. What should I do to change this? I couldn't find any setting for this.

Has there been some change in Ensemble since 2015 in viewing time? In 2015 (when I last time worked with Ensemble) it was local time in message browser and event log.

Unfortunately, this is not a correct answer. I want to change so that the Ensemble management portal shows local time. This answer was how to change UTC to local time in code.

After changing %Service_Telnet to "enabled" this worked.

%Service_Telnet can be found from: management portal -> system administration -> security -> services