Question
Yone Moreno · Feb 23, 2021

Is there any option to disable Ensemble SSL certificate validation in a REST Operation?

We would need some help,

Thanks in advance for your replies,

We can POST directly via POSTMAN only if we disable "SSL certificate verification"

 

We see the response:

 

However if we turn on "SSL certificate verification" it shows:

 

So, when we use Ensemble and a REST Operation, it outputs:

ERROR <Ens>ErrException: <THROW>zdoLoginToken+22^Operaciones.REST.HistoriaClinica.VacunasAPI.1 *%Exception.StatusException ERROR <Ens>ErrHTTPStatus: Recibido estado no correcto 403 del servidor HTTP remoto: 'HTTP/1.1 403 Forbidden' -- - registrado como '-' número - @' Set sc=tSC Throw:('sc) ##class(%Exception.StatusException).ThrowIfInterrupt(sc)'

 

How could we achieve to disable SSL validation in the REST Operation?

We are trying to connect to a https URL and we would need to turn off SSL validation in Ensemble

How could we turn off SSL validation in Ensemble?

We have read:

https://community.intersystems.com/post/problems-http-request-working-ou...

https://community.intersystems.com/post/rest-api-outputs-ssl-configurati...

 

Could you help us with document or examples?

 

$ZV: Cache for UNIX (Red Hat Enterprise Linux for x86-64) 2017.2.1 (Build 801_3_18358U) Tue Jul 24 2018 16:36:10 EDT
00
2 0 1 54

Replies

If using a pre-built outbound operation:

Those are the key settings (the checkbox is what you are asking about.)

In code on the %HttpRequest object, you're looking for

Set ..%HttpRequest.SSLConfiguration = "Default" (or whatever your SSL config name is)

Set ..%HttpRequest.SSLCheckServerIdentity = 1 (for true, 0 for false.)

Your error appears to deal more with authentication/authorization (HTTP 403) as I think SSL handshake failures throw a different status code but tinker with the settings above.