· Jul 29, 2016

Service not using updated schema???

I'm doing some Schema changes.  I used our existing standard schema as a base, which was already based on 2.3.  So let's call our existing one Custom.MHC.Schema (based on 2.3).  I created Custom.MHC.Schema.Advanced (based on Custom.MHC.Schema) and copied down one of the code tables then made a change to it.

When I ran a message through, the code table change didn't show up.  I noticed in the message viewer that the DocType is still Custom.MHC.Schema:ADT_A01 but the DocType Category is Custom.MHC.Schema.Advanced.

I have changed the HL7 Service Message Schema Category setting and I also tried setting DocType Resolution to "Ignore 9.3" but it still uses the old schema.

What do I do?

Discussion (1)0
Log in or sign up to continue

Hi Scott,

You'll probably need to copy over, from the base schema, all <SegmentStructure> that reference the custom code table, and all <MessageStructure> that reference those segments, and all <MessageType> that reference those message structures. Please give it a try and let us know how it goes. In case it's still not working as expected, please post the full custom schema and the base schema for further discussion, or contact WRC for further assistance.

Best Wishes,