Question
Yatin Desai · Jan 11, 2021

Not able to start Cache Terminal in RDP from Mac OS

We've our Cache running on Windows 2012 Server, but I've a Macbook Pro. Earlier I was using Miscrosoft Remote Desktop 8, to remote into our Windows server & everything worked.

Since version 8 is discontinued, I installed Microsoft Remote Desktop 10.5, which works for everything except starting Terminal.

I get error 'NTI Connection Error'

(287) Error writing to Pipe
Reason: (998) Invalid Access to Memory Location.

If I do remote desktop from Windows machine (using same credentials), it works.

Earlier I'd kept both version 8 & 10, to work around this, but with recent MacOS update to 11.1 Big Sur, version 8 no longer works, so I'm forced to use version 10.5 for RDP, but can't start terminal

Do I need to change any settings ?

Thanks,
Yatin

Product version: Caché 2017.1
00
1 0 2 86
Log in or sign up to continue

Replies

Hello Yatin,

That's a known RDP issue that has been fixed in modern versions of Caché. To get around it you can use ccontrol console:

Using Multiple Instances of Caché

"ccontrol [run | console | cterminal] instname    Runs Caché in programmer mode with either no device, the console, or the terminal for $Principal (Windows only)."

Thanks for quick help.