Question
Nigel Salm · Apr 22, 2021

Installing ZPM

NigelTSalm

Hi, I am loading zpm for the first time. I downloaded the %ZPM.Installer xml file and then tried to import it trough the Cache Studio. It threw up 4 errors Compilation started on 04/22/2021 23:41:53 with qualifiers 'cukb /checkuptodate=expandedonly' Compiling class %ZPM.Installer Compiling routine %ZPM.Installer.1 ERROR: %ZPM.Installer.cls(ExtractPackage+2) : MPP5610 : Referenced macro not defined: 'FileTempDir' TEXT: Set pFolder = ##class(%File).NormalizeDirectory($$$FileTempDir) ERROR: %ZPM.Installer.cls(Make+6) : MPP5610 : Referenced macro not defined: 'FileTempDir' TEXT: Set tmpDir = ##class(%File).NormalizeDirectory($$$FileTempDir) ERROR: %ZPM.Installer.cls(ExtractPackage+2) #1002: Invalid character in tag : '##class(%Library.File).NormalizeDirectory($$$FileTempDir)' : Offset:61 [zExtractPackage+1^%ZPM.Installer.1] TEXT: Set pFolder = ##class(%Library.File).NormalizeDirectory($$$FileTempDir) ERROR: %ZPM.Installer.cls(Make+6) #1002: Invalid character in tag : '##class(%Library.File).NormalizeDirectory($$$FileTempDir)' : Offset:62 [zMake+4^%ZPM.Installer.1] TEXT: Set tmpDir = ##class(%Library.File).NormalizeDirectory($$$FileTempDir) Detected 4 errors during compilation in 0.130s. I am also watching the Video on how to use zpm and the instructor says, download the installer and import and compile. So where am I going wrong?

I am loading it into Ensemble 2018

I also tried installing it using $system.OBJ.Load(...) with the same result

Product version: Ensemble 2018.1
$ZV: Cache for Windows (x86-64) 2018.1.3 (Build 414U) Mon Oct 28 2019 11:18:40 EDT
10
2 0 3 52
Log in or sign up to continue

Replies

I have found the answer. ZPM will only run on IRIS. So I will load it into my IRIS installation instead. 

Yes! 2 months ago I tried on HealthShare Health Connect 2018.  Even If you fix missing macro, zpm uses classes which exist only on IRIS.