Installing CSP Gateway on Ubuntu Server.

Hello, I'm trying to install CSP Gateway on Ubuntu 18.04 (Apache) with the installer CSPGateway-2018.1.1.638.0-lnxubuntux64.tar.gz but it doesn't seem to work.  I keep getting access-denied when I try to open CSP-pages or the CSP Management portal.

Does someone have an installation-manual or so ?

  • 0
  • 0
  • 98
  • 4
  • 1

Answers

Such message can be shown when you don't have enough license units. Do you have activated license there?

As you trying to install 2018.1.1, I suppose that you trying to connect it to IRIS, and maybe you just don't have a license for IRIS.

I'm trying to install CSPGateway-2018.1.1.638.0-lnxubuntux64.tar.gz on Ubuntu Server 18.04 to connect to an existing Caché 2016-server with license.  I keep getting access denied from Apache and http://cspgateway/csp/bin/Systems/Module.cxw is not working.

Forbidden

You don't have permission to access /csp/bin/Systems/Module.cxw on this server.


Apache/2.4.29 (Ubuntu) Server at 192.168.143.142 Port 80

apache2.conf :

#### BEGIN-ApacheCSP-SECTION ####
LoadModule csp_module_sa "/opt/webgateway/bin/CSPa24.so"
CSPModulePath "/opt/webgateway/bin/"
CSPConfigPath "/opt/webgateway/bin/"
Alias /csp/ "/opt/webgateway/cache/csp/"
<Location "/csp/bin/Systems/">
    SetHandler csp-handler-sa
</Location>
<Location "/csp/bin/RunTime/">
    SetHandler csp-handler-sa
</Location>

<Directory "/opt/webgateway/cache/csp">
    CSPFileTypes csp cls zen cxw
    AllowOverride None
    Options MultiViews FollowSymLinks ExecCGI
    Require all granted
    <FilesMatch "\.(log|ini|pid|exe)$">
        Require all denied
    </FilesMatch>
</Directory>
<Directory "/opt/webgateway/bin/">
    AllowOverride None
    Options None
    Require all granted
    <FilesMatch "\.(log|ini|pid|exe)$">
         Require all denied
    </FilesMatch>
</Directory>
#### END-ApacheCSP-SECTION ####
#### BEGIN-ApacheCSP-SECTION-CACHE ####
Alias /cache/csp/ "/opt/webgateway/cache/csp/"
#### END-ApacheCSP-SECTION-CACHE ####
 

It seems that the folder /opt/webgateway/cache/csp wasn't created.

Creating the folder solved the problem !