Implement the Activity Monitor in a Sharepoint Page

Primary tabs

Monitoring, Frontend, Caché

Hello, 

I would like to implement the Activity Monitor in a Sharepoint page. 
How is it possible to integrate only the Zen element?

Is it necessary to develop a CSP application in which this element exists?

Has anyone done this before and can I get a tip?

With kind regards
Armin

  • + 1
  • 0
  • 311
  • 9
  • 1

Answers

Armin,

I took a quick look and the good news is that the Ensemble Management Portal is just wrapping a DS Dashboard.  This means that you can stick this in an iFrame in SharePoint (I think this is called the "Page Viewer Webpart") and point the source to the DeepSee Dashboard Viewer page with the Embed flag turned on.  E.g.  the following link works for me:

http://localhost:57772/csp/ensdemo/_DeepSee.UserPortal.DashboardViewer.zen?EMBED=1&NOBORDER=1&DASHBOARD=Ens%2FDeepSee%2FActivityVolumeAndDuration.dashboard 

Based on your URL above, give this a try:

http://ntvensemble03/csp/activity/_DeepSee.UserPortal.DashboardViewer.zen?EMBED=1&NOBORDER=1&DASHBOARD=Ens%2FDeepSee%2FActivityVolumeAndDuration.dashboard

Report back and let us know if this works, and don't forget to "Accept" the answer if it does :)

Comments

What is the URL for this page?  I can't seem to find it in my Ensemble instance.

Hi,

actual is the URL

http://ntvensemble03/csp/activity/EnsPortal.ActivityVolumeAndDuration.zen?$NAMESPACE=ACTIVITY&$NAMESPACE=ACTIVITY&

Thanks for this! I added an Answer which I think should work based on this information.

As email notifications seem to be having issues you may not have seen the answer yet.  When you do, please let us know if it works.

Hi, thank you so much, yes, it works the way you described it. 
I have extended the call with a username/password. This also works as long as I assign %ALL permissions to this user. 
Unfortunately, it does not work with any other role.  

The %Ens_Dashboard: Use is assigned to the user, also the RW authorization for the db's.
I'm sure it's a little something.... 
 

 

Not connected with datasource

 

Kind regards 

Armin

Did you turn on auditing in order to see what sort of a <PROTECT> is being thrown?

You may need to connect with the WRC if you're having a hard time finding the privs to give to the user.

Yes, the audit is activated, but does not issue a message. (all active)
I'll contact the WRC. 

I thank you anyway and will contact you when this is fixed. :-)

 

 

You are most welcome - good luck!

Last thought - depending on the data that you have in your system and how exposed the server is, one possible solution is to create a new web application which only allows the Dashboard viewer to be served up, and then uses "Matching Roles" feature to look for a certain role that people needing this dashboard should have, and assigning the elevated privs required to see the dashboard to the Web App.  This would allow you to give access to people without having to broadly expand their assigned privileges.  Depending on how much you have to give them in order for them to see the dashboard, this may be something that you want to consider.

Hi, excuse the late reply.

the problem was an error in Ensemble 2016.1 version regarding the resource query in the Ens.DeepSee.ActivityVolumeAndDurationKPI  

// Parameter RESOURCE = "%Ens_Dashboard:USE";

Parameter RESOURCE = "%Ens_Dashboard";

After adding the permissions it worked so far, but I had to add the deep sea resource to the user.

DB_activity rw
%DeepSee_Portal u   
%Ens_Dashboard u
%Ens_Portal

 

Kind regards

Armin

 

Glad to hear it is working!

Could you please mark the Answer below as accepted so that people know that it worked?