How do you sort a DeepSee Pivot Table by Row Label?

Primary tabs

Working on "HealthShare 2019.1 [HealthShare Modules: Core:17.0.9941 + Patient Index:17.0.9941 + Clinical Viewer:17.0.9941 + Active Analytics:17.0.9941] - Cache for Windows (x86-64) 2018.1.1 (Build 312_1_18859U) Tue Mar 19 2019 00:43:30 EDT"

In creating a DeepSee Cube - Pivot - Dashboard I am not finding out how to sort my rows by the row label value.

My Rows are numeric values, but they are sorting lexically not numerically. By this I mean that given the  Row Values 1, 2, 3, 10, 100 the rows ar being displayed in the Analyzer  in the alphabetic order of:

1 followed by 10 followed by 100 followed by 2 followed by 3

and NOT the desired value/numeric order of:

1 followed by 2 followed by 3 followed by 10 followed by 100

When trying to sort the Pivot table specification for the column, none of the sorting options give the desired result.

Can someone please point me to the correct methodology for getting these rows to be in numeric order?

  • 0
  • 0
  • 34
  • 0
  • 1

Answers

The place to specify the sort order for a level is in the cube definition. In the Architect, open the cube you are using, select the level that you want to change the sort order for, and look at the Details panel for that level (on the right-hand side of the Architect page). In the "Sort option" dropdown, choose "asc numeric", and then compile your cube definition. (It is not necessary to rebuild the cube after making this change.) You should then be able to refresh the Analyzer, put the same level on rows, and see that it sorts in ascending numeric order.