· May 7, 2019

How do I get Atelier 1.3 to successfully Open DTL without bogus "Internet Explorer 7" fail?

When I try to open a DTL in the tabbed editor I always get this error:

You are using Internet Explorer 7. This version is obsolete and is not compatible with diagram editors. Please update Internet Explorer to a recent version.

My actual Internet Explorer is version 11.

I'm running Eclipse Photon.

  Atelier IDE    1.3.141    InterSystems Corporation

The same error occurred with Atelier 1.2 on Eclipse Oxygen. I've never been able to get this to work.

It seems hard to believe that no one has solved this problem, but I never found any solution at Developer Community. 

Discussion (5)0
Log in or sign up to continue

My understanding is that the BPL and DTL graphical editors in Atelier always use Eclipse's internal browser. It may be that your IE 11 browser is running in compatibility mode when embedded in Eclipse. Within the internal browser in Eclipse you can right click and select "View source". You may see something like this at the top:

<meta http-equiv="X-UA-Compatible" content="IE=9" />

You can find more information about Eclipse's internal browser and use of the X-UA-Compatible meta tag here. Can you send the contents of this <meta> line on your system?

It also may help to check the User-Agent header sent by the internal browser to the server. To find that:

  1. In a Caché Terminal enter the commands:
    kill ^%ISCLOG
    set ^%ISCLOG = 3
  2. Open a BPL or DTL in Atelier and switch to the graphical view
  3. Enter this command in Terminal:
    set ^%ISCLOG = 0

When you look at the ^%ISCLOG global there will be a $LISTBUILD like:

^%ISCLOG("Data",640,0) = $lb(900,,0,5628773246,"A"_$c(151,27)_"S"_$c(136)_"hÇ"_$c(155)_"ÙW¢·¡«"_$c(133)_"¤"_$c(148,159)_"©þÔ"_$c(20)_")5"_$c(144)_"ë"_$c(147,141)_"k"_$c(134)_"¢ë",2,"ENSDEMO","000000010000UnXM5atTr5Ar5MJaHkIPotZHaHeXwjNBDx3Mg3",,0,"","UnXM5atTr5",2,1,"/csp/ensdemo/",$lb("UnknownUser","%All","%All",64,-559038737),"","","","2019-05-14 19:52:24","2019-05-14 19:52:26","","Mozilla/5.0 (Windows NT 6.1; Win64; x64; Trident/7.0; rv:11.0) like Gecko","","",0,"","","","%iscmgtportal:6NkD8rSSEIGztlvX2WoQ0Q--",0,"",$lb("%iscmgtportal:6NkD8rSSEIGztlvX2WoQ0Q--"),"","","")

Send the User-Agent value (bolded in my example) as well.

The other option that might help is to change your system default browser. Can you test by making a different browser the default on your machine?

If none of these options do the trick it will probably be worth opening a new WRC case (by calling +1 617-621-0700 or emailing That way an advisor can take a look at additional system-specific information.

OK so I have now got this working after a lot of googling etc.  In the registry at Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION ensure you have a REG_DWORD entry for eclipse.exe with a  Decimal value of 11001

Hopefully this should help anyone facing this issue.