Question
Steve Pisani · Jul 3

Errors installing OpenExchange git-source-control using ZPM

Hi,

I have tried to install the module git-source-control into my USER namespace, but get the following error.

ERROR! ObjectScript error: SQL error(s) have occurred during the running of the 'statsINFO()' method.  Invoke the following method for additional details: set errID=##class(%SYS.PTools.Stats).getPToolsError(...)  WHERE errRowID={2763|2764}>
  > ERROR #6084: Unknown errors detected, but no error code reported

 

This module works from other namespaces.   I decided to re-install the latest published version of ZPM, and tried to install git-source-control class again and get this now:

ERROR! ObjectScript error: <CLASS DOES NOT EXIST>%GetClass+5^%ZPM.PackageManager.Developer.Extension.SourceControl.Interface.1 *SourceControl.Git.Extension
  > ERROR #6315: Errors reporting importing XML subelement in file 'C:\InterSystems\IRIS\mgr\.modules\USER\git-source-control\2.0.1\module.xml' at line '3' offset '43', skipping this item.

As git-source-control is still working from other namespaces, I do not know what is messed up here. From the last message, there seems to be some inconsistencies between this module and the required version of ZPM.

How do I recover ? 

Also - I'm assuming ZPM is backward compatible and can be updated at anytime, without effecting existing installed modules, or previously published modules..

 Thanks - Steve

Product version: IRIS 2021.2
$ZV: IRIS for Windows (x86-64) 2021.2 (Build 649U)
0
0 246
Discussion (3)2
Log in or sign up to continue

Hi @Steve Pisani - the same issue was reported via GitHub issues a little while back (https://github.com/intersystems/git-source-control/issues/137) but discussion trailed off and there wasn't any information there on the resolution.

You should always be able to upgrade zpm. I think the issue with <CLASS DOES NOT EXIST> error could be solved by running:

do ##class(%Studio.SourceControl.Interface).SourceControlClassSet("")

then reinstalling, then reenabling SourceControl.Git.Extension as the source control class for the namespace.

Ultimately something funky is going on with SQL stats collection. Given a bit more info it might be possible to mitigate the issue in the git-source-control package. Happy to connect sometime to discuss/troubleshoot.

From a diagnostic perspective, I think the things to do (which we would do on such a call) would be:
* Force single-process compilation: Do $System.OBJ.SetQualifiers("/nomulticompile")
* Running a fancy zbreak command:
zbreak *%objlasterror:"N":"$d(%objlasterror)#2":"s ^mtempdbg($i(^mtempdbg))=%objlasterror"
* Force single-process load of the package (zpm "install git-source-control -DThreads=0")

Then look at the contents of ^mtempdbg to figure out where our errant %Status is coming from and go from there.

I have logged an issue with the ZPM community on github now as this happens when I install any ZPM module, not just git-source-control.

I tracked this issue to $System.OBJ.Load() only apparent on IRIS 2021.2.  after upgrading to IRIS 2022.1, this issue went away.

Hope this helps others.