Question
Smythe Smythee · Nov 7

Ens.Alert

Hi Community,

I am working on sending Gmail with error details when any errors occurs in the ensemble production.

I am facing the below issues while doing it

1.I have Ens.Alert (Business process) using the class Ens.Alerting.AlertManager and Emailoperation (Business operation) using the class EnsLib.EMail.AlertOperation. here my business process is not sending the Alarm request to business operation eventhough i am using rule to connect the business operation 

2.What are SMTP server details needs to given for Gmail?

 

Please let me know how to resolve these issues

 

Thanks,
Smythee

Product version: Ensemble 2018.1
$ZV: Cache for Windows (x86-64) 2018.1.1 (Build 312_1_18937U) Fri Apr 26 2019 17:58:36 EDT
0
0 103
Discussion (2)1
Log in or sign up to continue

Smythe,

Did you have a chance to review the replies on your other post? Are you trying to use the managed alert framework? If so, I'd suggest reviewing that documentation to make sure your configuration is appropriate. It sounds to me you may just want a regular router, and not to use the AlertManager, in which case a simple business rule can do that routing (or if you don't need routing, you can just make the email operation the Ens.Alert component.)

I think the following Google page explains the SMTP settings you need:

https://support.google.com/a/answer/176600?hl=en

Hi ,

I have gone through the previous post replies and i am able to configure the Business operation but i didnt mention  my exact problem in the post.

I am getting "Unable to open TCP/IP connection" error so i thought i made any mistakes in SMTP connection settings