DeepSee passing Filters in Dashboard URL

HI

-- We have our Pivot ready for some data for all accounts. And we want to now filter it by Account

[Account].[H1].Account.&[1]

It works fine at the pivot level and it filters the records. We save the pivot with no filter values as we want users to decide the Account they want to filter for

-Now If i save this pivot without a value of a filter , then obviously it has all records and I want to filter it at the Dashboard level on my page.

URL I am passing

......dashboard&SETTINGS=FILTER:[Account].[H1].[Account].&[1]&NOTITLE=1

The filter doesn't work If I pass it this way. However dashboard is working fine and its showing records of all Accounts. Just the filter part isn't working. So its definitely a very small issue where I am not passing the filter in the URL how deepsee likes.

  • 0
  • 0
  • 66
  • 1
  • 1

Answers

Hi Neerav,

I believe the correct syntax is to just use & (not &) for the ampersand before each parameter, and to use %26 (not &) for the ampersand before the member key. So your URL would be something like

....dashboard&SETTINGS=FILTER:[Account].[H1].[Account].%26[1];&NOTITLE=1

Please give this a try and let me know whether it works.

Thanks Samuel

Yes this does work if we use it as a direct URL on browser.
Just a small change that when we pass it through Zen it has to be slightly different & has to be & 

..dashboard&SETTINGS=FILTER:[ACCOUNT].[H1].[ACCOUNT].%26[1]&NOTITLE=1