Business Service Delete Error

While processing large HL7 files via ftp the Business Service errors when trying to deleting the file.  All the messages process fine just the delete step errors.  Is there is setting that would help this?

  • 0
  • 0
  • 29
  • 3
  • 1

Answers

Two ways to solve this error:

  • Change permissions for the OS user you use to connect to the FTP so the user can delete (write permission) files
  • Set service setting DeleteFromServer to 0

We would want the Business Service to delete the file, which it can do just fine if the file is smaller.  I have tried a file in the KB; file is deleted no error.  Same process tried a file 34 megs and the delete error happens.  It seems like it might be trying to delete the file before the Business Service or Business operation has finished processing the messages so it see the file as being is use.  If so that is true, is there a way to slow down the delete process to give time for the give time for processing to finish.

Are you using EnsLib.FTP.InboundAdapter?

Deletion happens after file is processed.

What error are you getting?

File size absolutely should not affect deletion result.

Yes, I am using EnsLib.FTP.InboundAdapter.

Error doesn't say much "ERROR <Ens>ErrGeneral: Failed to delete 'testfile.dat'
from FTP server after successful processing - :"