Atelier Search seems broken? Replace Cache with IRIS.

Primary tabs

Hi, I have Atelier working. When I try to search the entire RPMS code base for Cache to replace with IRIS I get this on Altelier search:


An internal error occurred during: "Atelier Search".
Failed to read /api/atelier/v2/RPMS/action/search?query=.%2ACache.%2A&

  • 0
  • 0
  • 47
  • 3
  • 1


just a guess:

with 850 chars length, this looks somewhat oversized.

and the query itself doesn't make much sense:


I doubt that you have all those file extensions available in Caché  or IRIS

Reduce it to the few useful ones that you konw from Studio:



why don't you use your source control for this type of text search?

Thanks for the response, I will use anything that will work. Goal is to replace the word Cache with IRIS. I did use %RCHANGE which somewhat worked.  It errored on some of the instances of Cache but succeeded in others.  What would source control for IHS FOIA RPMS in a CACHE.DAT benefit? 

In Altelier I tried just .int as an extension and get this: An internal error occurred during: "Atelier Search".
Failed to read /api/atelier/v2/RPMS/action/search?query=.%2ACache.%2A&

-- IV

I'd expect better text search in a source control repository.
Anyhow there is either a bug or a setup problem related to your Error msg in Atelier.

Do you have any Windows based PC available to use Studio ?