Accessing a new DeepSee Namespace for the first time

Whether you are accessing DeepSee for the first time ever or you are configuring DeepSee on a new instance, there are two common issues that are encountered after clicking on the “DeepSee” option in the System Management Portal.

Issue #1: Architect/Analyzer is grayed out!

Issue #2: DeepSee must be enabled before use.

Issue #1: Architect/Analyzer is grayed out!

There are two common causes for this problem.

Cause 1 - License

Cause 2 - Security

The first common cause is that the license does not have these DeepSee options enabled. To confirm if these options are enabled, you can run the following code from terminal:


	do $system.License.Decode()


This table describes what License options must be enabled to access each DeepSee component:

DeepSee ComponentLicense Decode Output
DeepSee AnalyzerDeepSee Analyze enabled.
DeepSee ArchitectDeepSee Model enabled.

 

Once a license with these options is activated, the SMP links should be available.

 

The second common cause is that the user does not have sufficient privileges.

To access DeepSee Analyzer, the user must have: %DeepSee_Analyzer

To access DeepSee Architect, the user must have: %DeepSee_Architect

Further details about DeepSee Resources can be found here: http://docs.intersystems.com/latest/csp/docbook/DocBook.UI.Page.cls?KEY=D2IMP_ch_security#D2IMP_security_overview

 

Issue #2: DeepSee must be enabled before use.

All web applications that use DeepSee must be enabled before using the web interface. There are two ways to enable DeepSee.

Pre-2015.1: http://docs.intersystems.com/latest/csp/docbook/DocBook.UI.Page.cls?KEY=GCSP_config#GCSP_appaccess_deepsee

2015.1 And later:

http://docs.intersystems.com/latest/csp/docbook/DocBook.UI.Page.cls?KEY=D2IMP_ch_setup#D2IMP_setup_web_app

 

There are multiple ways a “DeepSee Disabled” namespace will present itself when trying to access DeepSee through a browser.

The first way is seeing a Forbidden message or HTTP 403 Forbidden from your browser when trying to access a DeepSee Management Portal page. Different browsers and different Caché versions will present this error in different ways. Here is the same URL being requested from Firefox and Internet Explorer:

There have also been cases where a CSP error page is shown with a status of 403, which is the Web Server error code for Forbidden.

Work has been done in the SMP to avoid making these Forbidden errors unreachable. If a namespace is selected that does not have DeepSee Enabled and you click on the “DeepSee” option, you should see a message that says “The <namespace> namespace does not support DeepSee.” This means that DeepSee is not enabled and one of the previously mentioned methods should be used to enable DeepSee.

 

It is now time to access DeepSee and share any interesting solutions and insights with the community!

 

  • + 5
  • 0
  • 817
  • 1

Comments