Recent posts:
Recent replies:

One difference I see between your set up and mine is that I have aa AMD Ryzen 5 2600 Six-Core Processor  3.40 GHz and you have an Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz. I think its unlikely that Intel vs. AMD is the cause but who knows.

Could you go into more detail about the steps you took to use your Docker-Compose File? Did you use it with "docker-compose build" or "docker-compose up"?

I think that "docker-compose build" is ignoring the "cpuset: "0-1" while creating the docker iris image at my computer. Because you do not exeed 8 cores this would not be a problem for you and when you start the container it somehow starts to use this setting (as shown by your section "With this Limitation:").

Sorry, does not work for me. I still get "Too many Cores (12) for InterSystems IRIS Community License." when running "docker-compose build".

Please forgive me if I am mistaken but the "Without section" looks to me as if you do not have more than 8 cores with and without limitation.

I gave up to modify docker-compose.yml.

I commented out the last line of the Dockerfile:
# RUN iris start IRIS  && iris session IRIS < /tmp/iris.script && iris stop IRIS quietly

Now I did a "docker-compose build" but because I did not start iris I did not get my "exceeded core limit" error.

But I got a "Successfully tagged objectscript-docker-template_iris:latest"

With this I could "docker run --name iris --cpuset-cpus=0-7 -d --publish 1972:1972 --publish 52773:52773 objectscript-docker-template_iris:latest"

In the same directory I did "docker exec -it iris bash"

Then you have to do a "iris session IRIS < /tmp/iris.script" and a "iris terminal IRIS"

Finally you can test it with "w ##class(dc.PackageSample.ObjectScript).Test()"

If you use Visual Studio Code you have to change your setting.json as follows:

{
    "objectscript.conn" :{
      "active": true,
      "host": "127.0.0.1",
      "port": 52773,
      "username": "SuperUser",
      "password": "SYS",
      "ns": "USER"
    }
}

Followers:
Stefan has no followers yet.
Following:
Global Masters badges:
Stefan has no Global Masters badges yet.