User bio
404 bio not found
Member since Apr 1
Replies:

The Stream is a Blob of an image that has 2.830KB

This blob was inserted on Caché the exacly same way and works, but for that we had to enable the Long Strings config.

When trying the same SQL on IRIS I'm getting the MAXSTRING error, that I suppose it's because the Long Strings config is not enabled.

Please correct me if I'm wrong, but I really don't see any other thing that could be causing that.

It's the first time that I'm using IRIS so it's very possible that I'm missing something, but considering previous experiences with Caché the first thing that comes to my mind is this config.

When looking on IRIS documentation I only find the path "System Administration > Configuration > System Configuration > Memory and Startup > Enable Long Strings."
But when oppening it on IRIS Management Portal the "Enable Long Strings" config just does not exist.

When Inserting on a table with the following SQL:

INSERT INTO ERP.Arquivos (Blob, Descricao, FileName, MimeType, IDIntegracao, Updated, UpdateUser, Inserted, InsertUser) VALUES ({Stream}, 'some Description', 'filename.jpg', 1, 10, CURRENT_TIMESTAMP, 'username', CURRENT_TIMESTAMP, 'username')

Inner Exception: [SQLCODE: <-400>:<Ocorreu um erro fatal>]
[Error: <<MAXSTRING>zExecute+5^%sqlcq.RODOFORCE4.cls54.1>]
[Location: <ServerLoop>]

----------------------------

This SQL works fine when dealing with small streams, but on some larger files I get the error above.

I figured it was the long strings because we had the problem with large SQL's on Caché and we needed to enable the Long Strings Config.

Certifications & Credly badges:
Antonio has no Certifications & Credly badges yet.
Global Masters badges:
Antonio has no Global Masters badges yet.
Followers:
Antonio has no followers yet.
Following:
Antonio has not followed anybody yet.