Recent posts:
Alexander has not published any posts yet.
Recent replies:

 I have been under 4 tabs (overview, Pages/Threads, Content Types and Categories.) The only things I have ticked are on the pages/Threads page and are the overall subscribe checkbox and the On updates and On comments tick boxes for two threads I  want to follow at this time. (this thread and one other.  ) Under the Content type the tick boxes are all un-ticked (subscriptions, Answer and Post.)   For Categories  Overview it tells me I have 2 selected items but under Categories tab I have 0 Tags and The groups section tells me it is restricted and  I do not see any tick boxes on the page.

 

Just before your update I received and email entitled "[ISC-DC] Encoding issues ..." which is an issue I am not explicitly trying to watch. When I click on the Purple Unsubscribe at the very bottom of the email. I end up at the Subscriptions -> Pages/Threads page again and there is no  line item for the Encoding Issues thread, only the two threads I want to follow.   

I do not claim to be a  Huge Pages expert, but I have been doing some more reading on Transparent Huge pages and the madvise option.  The following is untested and un-verified.

It seem like if you are running Kernel 2.6.38 or newer that you may be able to use the madvise instead of never for the Transparent Huge Pages setting. According to http://manpages.ubuntu.com/manpages/trusty/man2/madvise.2.html the 2.6.38 kernel’s madvise has a MADV_HUGEPAGE option, that allows applications to enable Transparent Huge pages, If no MADV_* flag is thrown then it defaults to MADV_NORMAL or no special treatment. I believe this means that transparent huge pages should be off by default.  

If you are using RHEL 6 or probably most of its derivatives even though they have a madvise setting for their Transparent Huge pages settings it appears RHEL did not backport the MADV_HUGEPAGE Option to their madvise/Kernel (At least 2.6.32-504.81 and lower), so you have to set the box’s transparent Huge pages to never.   (Man page in RHEL 6 with kernel= 2.6.32-504.8.1 lacking a MADV_HUGEPAGE and https://groups.google.com/forum/#!topic/tokudb-dev/_1YNBMlHftU Bradly Kuszmaul’s 5/8/13 post.)

RHEL 7 & it’s derivatives are running the 3.X kernel and that man pages show a  MADV_HUGEPAGE option so it looks like you can set the box to madvise and it will not use transparent huge pages.

Once again I am not a Transparent Huge Pages expert and have not done any testing to verify the validity of this.

 

Of course their is no replacement to actual testing. What I am trying to say is that had I started reading the article  straight through instead of skimming and jumping to the how to check if it was on, I probably would have  read at the top "various Linux distibutions introduced Transparent HugePages with the 2.6.38 kernel' and stopped because my kernel is less than that.  I really  think that the current wording will lead people whom work at shops that are still rolling out new builds in RHEL or Centos 6 not to use the ideal settings.     Maybe a complete re-arrange of the first three paragraphs into two or three paragraphs where the RHEL 6,...  might make this clearer.  With a sentence that reads something like, "This was first introduced in Red Hat Enterprise Linux 6, SUSE Linux Enterprise Server 11, and Oracle Linux 6; and then later introduced in may other Linux variants with the 2.6.38 kernel.

Additionally it might make things clearer if you where to mention that for It's setting the item in brackets is what is the current setting as in my redhat the lines reads .   [always] madvise never.

It might also be useful to people on this to mention what to do in the case where the transparent Huge pages enabled is set to madvise .    

Followers:
Alexander has no followers yet.
Following:
Alexander has not followed anybody yet.
Global Masters badges:
Alexander has no Global Masters badges yet.