The reason this wasn't working was because we weren't accepting ack's on this specific interface. It was causing a network queue buildup and not allowing a forced disable of the connection. Enabling ack's fixed the issue.