Some more errors in Atelier

Prefernces -> Atelier -> Colors - error in code highlighting. UPD: looks solved with build 590.

Preferences colors

 

Just in start of atelers when some project already initialized, with a quite big number of files in a project.

UPD: I don't see this message any more, but .log still contains this error

DLTK Indexing initialization error

 

Copy Routines to project copied INT files as well, for selected files/packages. If I select root folder Routines, and copy it to the project. Then will copied all avaliable INT/INC files from that namespace, even %*, and even generated as a source for classess. For root Classes folder, looks like the same problem with %*.

 

 

Comments

I've let the team know about the problems you reported.  Thanks for the detailed post of problems.

I haven't been able to reproduce the problem in the preferences screen with coloroing so suspect that this issue has already been addressed and will be available in the next Atelier refresh (coincides with the next 2016.2 field test beta posting).

 

The DLTK indexing initialization error is new and has been raised as an issue for our development team

 

Ref: Server view and copy of routines. There are server filters available for System and Generated files but they do not seem to be honored at the moment. I'll raise an issue for that to be addressed.

Thanks for the reports

The team is still working on the issues you raised but I'll let them know you've revised your problem report.

Cache for Windows (x86-64) 2016.2 (Build 595U) Wed Feb 10 2016 19:12:54 EST
Action `Delete` in context menu by project items, no works after first use.

 

 

Deleting three thousands of items at once leads to Atelier does not respond. In project folder nothing changes. And all that time CPU in ~70% and about 2Gb memory

 

 

I've opened a GitHub issue for the Atelier Team and assigned to Jamie Newton.  #1598