Question
Oliver Wilms · Mar 26, 2020

SMTP ERROR #6033: Error response to SMTP DATA: 500 #5.5.1 command not recognized.

Hello,

While working on my Iris contest application FileMailer, I got an error today trying to send email with code that used to work. I added debugging entries and I can see it happens in %Net.SMTP class "Send" method. I am not using any credentials or SSL. I see it opens |TCP|25 device. It issues a series of commands to SMTP server (I was testing with smtp.va.gov and port 25). "init" command gets 220 response.  It runs "Login" method. Response is 250. The next command is "MAIL FROM" and I see 250 in the response with sender ok. The next command is "RCPT TO". Again, response is 250 with recipient ok. The next command is "DATA". Here the response is 500 #5.5.1 command not recognized and the Send fails with error "ERROR #6033: Error response to SMTP DATA: 500 #5.5.1 command not recognized."

Has anybody else seen this error?

How can I proceed?

00
0 1 191 1

Replies

I tried this again today and it worked. No more errors. I did not change anything. I observed that the Login gets a response with a server name and today it is different compared to yesterday's server. Maybe the server I got logged in yesterday did not like me.