· Jan 5

SFTP connection problem


I have been facing a problem for several months, I have several flows that work in SFTP with the iris class EnsLib.FTP.PassthroughService

The problem is that from time to time I get an error message that says:

"A connection could not be established because the target computer expressly refused it"

I had the case for a server at our house and we solved the problem by extending the call interval parameter to 60 seconds,

However I have the same error for an external server with exactly the same configuration as the first flow, I contacted their infrastructure department who told me that an SFTP connection was missing at the time of the error but they have no information and nothing in their logs.

Concretely, this does not prevent the flow from working because on the next call, everything works again, however the node remains in red until there is a new "ConfigItem" and this therefore sends us an alert email and above all passes our production in error on our supervision tool which is connected to the Iris API monitor

Besides, I don't understand what this famous ConfigItem corresponds to which happens quite randomly like here for example.

Do anyone else have streaming SFTP streams? Have you ever had this problem ?

Thanks in advance

Discussion (3)3
Log in or sign up to continue

Hello @Jean-Charles Cano,

messages starting with 'ConfigItem' are simply part of the informational messages in the event log indicating the start of a service/process/operation in production (specifying the process ID of the associated job).
According to your screenshots, this means that the connection failed on 12/27 at 04:25 and the service was successfully restarted (ConfigItem message), on 12/28 at 14:45, as well as on the same day at 2:50 p.m., 4:27 p.m., etc.
Maybe the problem is with the StayConnected = -1 setting.

Changing it to a positive value or to 0 will perhaps resolve the problem.