PDF Display from DeepSee UserPortal doesn't work

Hello Community,

I hope you are well.
I encounter a problem on IRIS for Unix 2020.1  when I try to create a PDF from a simple Dashboard on Deepsee : 

When I click on this widget , a tab appear and is loading for ~30 seconds, then shows 'error loading the PDF File ' :

 

 

I am also using DeepSee Web, and i encounter a problem if I try to Export the graph as a PDF : 

 

Is there a link between both problem ? ( If I fix the print widget, the PDF Export will also be fixed ? ) 

I found someone having the same problem but she fixed it : https://community.intersystems.com/post/unable-run-oscommand-print-widget-deepsee
I checked in the mgr/Temp file , and i have the "widget.xsl" file generated, but no "widget.pdf"  .

I also tried to execute the following command on  my  docker container : 
 /usr/irissys/fop/fop -fo test.xsl -pdf test.pdf -c /usr/irissys/fop/conf/fop.xconf 


But it results as an error : 
Caused by: org.w3c.dom.DOMException: The current document is unable to create an element of the requested type (namespace: http://www.w3.org/2000/svg, name: svg:link).   

Do you have any suggestion on how to debugg the PDF generation ? 

Thank you in advance.
I wish you a good day 

 

Lucas Bourré

  • 00
  • 0
  • 115
  • 9

Replies

There is no svg:link element.  The svg:a element is used to specify a link.

It would help to see the xsl file to which your refer to further understand what is going on.

Best Regards,

Jonathan

Hi Lucas,

This looks to me like a bug in InterSystems FO generation.  You should contact the InterSystems WRC.

I see the following code in the FO:

<svg:link type="text/css" rel="stylesheet" id="dark-mode-general-link"  />
<svg:link type="text/css" rel="stylesheet" id="dark-mode-custom-link"  />
<!--  SVGStyle: %ZEN.SVGComponent.svgPage  -->
<!--  SVGStyle: %ZEN.Component.page  -->
<!--  SVGStyle: %DeepSee.UserPortal.standardPage  -->
<!--  SVGStyle: %DeepSee.UserPortal.DashboardViewer  -->
<!--  SVGDef: %ZEN.SVGComponent.svgPage  -->

While the comments are fine, the svg:link element should not be there.  Something else should be there instead.

HTML has a link elment and it looks like svg:link is supposed to be an HTML element, or maybe the generation for HTML intruded into the generation for PDF.

Alright I'm opening a ticket, I understand the problem.
Thank you for your time and your explanation ! 

I fixed the problem with the support.
The XSL file was containing 'svg:link' because it was generated from my browser, which contain a 'Dark Mode' plug-in .
Then the FOP was unable to convert the SVG into a PDF, because the SVG il build from the HTML content of my browser.

After disabling the Dark Mode Plug-in , my PDF is now printing properly.
Best regards,

Lucas Bourré

Hi Lucas!

Could you confirm that DSW export to PDF doesn't work for you here? What do you have as the result with PDF?

Hello Evgeny, 
I still have some problem with DSW export but this is not related to this problem.

I have some error with the ##class(%Net.Remote.Utility).RunCommandViaZF()  command from the ReportGenerator, this one use the following line : 
Set pRetCode = $ZF(-100,cmdFlags,pCmd,.pCmdArgs)

This line returns a <NOTOPEN> Error.
A temporary file is created, but empty.

The $system.OS.ProcessError() returned  <2> No such file or directory.

I tried to manually create the file and launch in the Terminal the following command, but it didn't work : $ZF(-100,"/STDOUT=""/tmp/fichier.txt""/STDERR=""/tmp/fichier.txt""","echo toto")  

  
I'm still investigating the problem, I keep you informed !