InterSystems Official
Stefan Wittmann · May 21

IAM 2.3 is now GA (Generally Available)

The GA release is now published for the 2.3 version of the InterSystems API Manager (IAM).

 

The container for IAM, including all relevant artifacts to upgrade from earlier versions of IAM can be downloaded from the WRC Software Distribution site in the Components area.

 

The build number for this release is IAM 2.3.3.2-1. 

This release is based on Kong Enterprise version 2.3.3.2.

 

InterSystems API Manager 2.3 makes it easier to deploy in a secure manner and for high-availability scenarios  It has many new capabilities including:

  • Introduction of hybrid mode
  • Broader support for Docker Secrets

The hybrid mode allows you to deploy IAM nodes in a data plane and a control plane. While the data plane deals with the API traffic, the control plane is used to configure the data plane nodes and observe the telemetry from the data plane. This grants more flexibility in deployments and eases the effort to deploy for HA scenarios. More information on the hybrid mode can be found here. This capability will also be covered in more detail on the InterSystems Developer Community in the following days.

 

Documentation for IAM 2.3 can be found here. This documentation only covers elements that are specific to IAM. Documentation links within the product bring users directly to the documentation from Kong Enterprise.

 

Upgrading from IAM 1.5.0.9 requires incremental upgrades through two intermediary releases, which is described in further details in the documentation.

 

IAM is only available in OCI (Open Container Initiative) a.k.a. Docker container format. Container images are available for OCI compliant run-time engines for Linux x86-64 and Linux ARM64, as detailed in the Supported Platforms document.

 

Best Regards,

Stefan

30
1 0 0 153
Log in or sign up to continue