Log in or sign up to continue

You can read this article about it here. Something like this.

set ^CacheMsg("EnsColumns","en","RemoteArchivePath")="Remote Archive Path"

Wonderful! That always bothered me more than is logical, but after digging around at one point and not quite figuring it out I begrudgingly moved on. Glad I saw this!

Initially I couldn't get the change to take effect using "en" though. I needed to use "en-us" instead. That worked fine and makes sense given my locale of "enuw". Curiously though most digging around in globals seemed to indicate "en" and I'm not sure what actually indicates that "en-us" is the correct node to be used as everywhere I looked seemed to come up "en".

^CacheMsg("Arial,Tahoma,Verdana")="en"
                       "Confirm")pointer
               "EDIDocumentView")="en"
                           "Ens")pointer
                      "EnsAlert")pointer
                        "EnsBPL")="en"
                    "EnsColumns")="en"
                      "EnsDICOM")="en"
                       "EnsDemo")pointer
                        "EnsEDI")pointer
                 "EnsEDIEDIFACT")pointer
                     "EnsEDIHL7")pointer
                     "EnsEDISEF")pointer
                     "EnsEDIX12")pointer
                        "EnsEnt")pointer
          "EnsPushNotifications")pointer
                  "EnsRecordMap")="en"
                        "EnsSAP")="en"
                "EnsSearchTable")pointer
                         "EnsWf")pointer
                      "EnsXPATH")pointer
                      "EnsebXML")pointer
                      "Ensemble")="en"
                           "ITK")="en"
                    "RuleEditor")="en"
                      "Workflow")pointer
                "tahoma,verdana")="en"

 

^%SYS("LANGUAGE","CURRENT")="en"
^%SYS("LOCALE","CURRENT")="enuw"
 

w $mvv(58)
en

Maybe something to do with %SYS.NLS.Locale.cls or %SYS.NLS.int, and the exact details aren't really a big concern, but good to know if you find setting the global using "en" doesn't seem to work.

Thanks!

Aric