· Jun 29, 2018

Help with reconnecting an older Cache database after a server re-install

Lost the raid array on our server. We were able to recovery all the data from backup but now are running into road blocks getting the Cache database up and running. We are running version 5.0.7 which is quite old but works for our needs. Our most current road block it is getting CTTerm (Telnet) to connect with the database. After entering the user and password nothing happens beside the carriage return dropping down one more line in CTTerm.  If you are familiar with the older revs of Cache please feel free to contact me or provide input.  Any help or direction would be invaluable to us. RAM Technologies, Eau Claire, WI

Discussion (2)0
Log in or sign up to continue

You've left out some info (OS, OS version, firewalls, where you are running CTTerm, data path, etc) are some suggestions:

Does putting in wrong account/password yield same symptom?

1) If you are running CTTerm on the same box check to see if Cache Telnet server enabled, permissions good, local box firewall not interfering, Cache license appropriate/applied, etc.

2) If running CTTerm from network check above plus all applicable firewalls or network protections. Some networks may prevent old Telnet running across specific paths without opening up a hole.

3) If you are using terminal servers to old serial terminals or PCs check the terminal servers.

Tom Fitzgibbon | 3474648531 | gototomAtG...l

The workstations are a wide variety from XP to 10. The database access is within the LAN only. All firewalls are down. All networking hardware is unchanged. CCTerm32.exe is running a terminal from each workstation, then connecting to the database via local IP. The database is shared on a server running Server 2003 R2. The Cache program license is applied via a key file in the mgr folder and is not prompting that there is anything wrong there. The customer's database is mounted and shows up in the listing within the Cache Configuration Manager along with the default Cache.dat files.

ex: Database name: ABC and User: ABC

The end users say they initially connect to the database using CCTerm32.exe, entering a username and no password. In the Cache Control Panel -> Security -> User Accounts,  I set the username they requested and no password. Username: ABC, Namespace: ABC, Routine: %PMODE. Tried a few different routines, but unsure what it should be. 

When I connect via CTTERM32.exe to the local database server IP - they do get the prompt for user and password and can type in ABC with no password. I then get to a prompt like >USER or >ABC or can point to any of the other built in database cache.dat files.

After that the users say that they should be prompted to type in their own username and password. I tried adding users and passwords in the 'Cache Direct Users' security option but I don't know how to prompt for credentials from here. I have not found any scripts in the scripts folder within the data backup.

They also had a program called FACSGUI.exe that is set to point at the server IP and the correct namespace for their database. This also asks for user and password. When I try to connect with User Account credentials, or Cache Direct Users credentials I get an error: System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it at System.Net.Sockets.Socket.Connect(EndPoint RemoteEP) at fgProfileManager.frmProfileManager.CheckVersions()

Please advise.