Help with ERROR #5002: ObjectScript error: <PROPERTY DOES NOT EXIST>...Source,Ens.StreamContainer

I'm trying to convert a CSV inbound to an HL7 MFN^M16 outbound.  I know I'm using book information as the CSV but I don't think that matters.  Please let me know if that's incorrect. 

My service is reading the file in just fine and when I don't have a DLT transformer the raw message passes through to outbound file folder just fine.  However, when I include a basic DLT that simply copies a couple of fields over I get the "Ens.StreamContainer" error.  Everything also seems to be good in the Record Mapper.

I've been working through the documentation but I don't see anything that helps with this specific error.

https://docs.intersystems.com/healthconnect20191/csp/docbook/DocBook.UI.Page.cls?KEY=AFL_productions

 

 

What am I missing?

 

 

Record Mapper

 

The Rule

 

The Transformer Builder

 

Example CSV File:

Author|Title|ISBN|Format|Pages|Publisher|Publication_Date|Genre|Added_Date
"Kevin J. Anderson"|"Ruins (The X-Files)"|9780061057366|"Mass Market Paperback"|264|"HarperCollins"|"Feb 01, 1997"|"Mystery Fiction, Radio And Television Novels, Science Fiction, Suspense Fiction"|"May 18, 2018"

 

Errors:

ERROR #5002: ObjectScript error: <PROPERTY DOES NOT EXIST>zTransform+7^Pkg.DTLCSVBooks001.1 *%Source,Ens.StreamContainer +
ERROR #5002: ObjectScript error: <PROPERTY DOES NOT EXIST>zTransform+9^Pkg.DTLCSVBooks001.1 *Author,Ens.StreamContainer +
ERROR #5002: ObjectScript error: <PROPERTY DOES NOT EXIST>zTransform+11^Pkg.DTLCSVBooks001.1 *Title,Ens.StreamContainer +
ERROR #5002: ObjectScript error: <PROPERTY DOES NOT EXIST>zTransform+13^Pkg.DTLCSVBooks001.1 *AddedDate,Ens.StreamContainer
 

Using

IRIS for Windows (x86-64) 2019.1 (Build 510_0_18883U) Mon Apr 1 2019 14:26:51 EDT [HealthConnect:1.1.1]

 

  • 0
  • 0
  • 46
  • 4
  • 0

Comments

Which business service are you using to read the file? Are you using EnsLib.RecordMap.Service.FileService and specifying the record map type in the configuration?

It sounds like you might be using EnsLib.File.PassthroughService

I had it that way yes.  I've created a new Service with Classname "EnsLib.RecordMap.Service.FileService" and set the RecordMap to the correct one I'm using.  I ran into some issues but they were tweaks in the CSV file.  The Genre field was too long so I shortened the data.

Now when I play CSV file through the file is picked up, and disappears.  Nothing is happening within IRIS.  The Process never gets the file according to the logs.

I would double-check that a TargetConfig in the new service is set to the correct router. After that, I'd check the event log and see if there are any errors logged.

So I got it all worked out.  There were a couple of things I had mis configured. 

In the end I had the operation set to EnsLib.File.PassthroughOperation instead of EnsLib.HL7.Operation.FileOperation.

Thanks for all the help!