User Answers

This message means, that server-side Atelier API -- web-application /api/atelier -- is configured with only Unauthenticated access. So, even though you put Username/Password in Server connection dialog, they are cannot be used, as server-side configuration does not allow this.

To allow password authentication, open Management Portal, then go to Menu (top-left corner) -> Manage Web Applications -> [api/atelier].

Put checkbox near Password in "Allowed Authentication Methods". Save the web application

Hi Tani.

Having said that this seem to work OK on my Atelier 1.1.386 + Caché 2017.2,

you might check Error log and Network Activities for hints:

Window -> Show view -> Other ->

General -> Error Log
and
Atelier -> Network Activities

No. You need to wrap it as you showed in second example.

You can use "C" alias from first sample only in "ORDER BY" clause in the same query, not in WHERE.