I have one in my testing environment. According to https://community.intersystems.com/post/licensing-ubuntu-and-suse-20171-and-later, I should move to native Ubuntu build with 2017.2. So I downloaded Cache for UNIX (Ubuntu Server LTS for x86-64) 2017.2.1 and tried to update my existing 2015.1.4 installation. What I got was:

Upgrade from lnxsusex64 platform is not allowed.

No packages will be installed.

Meanwhile new Cache 2017.2 instance was installed without any problem.

The question is: how to upgrade an existing one?

Last answer 6 March 2018 Last comment 6 March 2018
0   0 3
148

views

0

rating

As previously announced, 2017.1 on VSI OpenVMS 8.4-1H1 is the final major version of Caché and Ensemble.  2017.1 will not be available for VSI OpenVMS versions beyond 8.4-1H1.

Maintenance releases of 2017.1 on VSI OpenVMS may be announced but only to deliver critical corrections.  2017.1 on VSI OpenVMS will be the Minimum Supported Version from July 1, 2019 through December 31, 2020.  After December 31, 2020, no further maintenance releases will be made available.

0   0 1
0

comments

280

views

0

rating

When defining a server connection in Atelier we are required to enter a username and password because these are mandatory fields in the dialog. However, if the /api/atelier web application definition on that server has only the "Unauthenticated" checkbox set in the section titled "Allowed Authentication Methods", then our Atelier connection will succeed even if we supply an invalid username and/or password.

Last comment 29 May 2018
+ 2   0 3
319

views

+ 2

rating

InterSystems has performed various system and application benchmarks to determine the potential performance impact after the corrections for Meltdown have been applied.

Overall our tests have shown at worst a performance degradation of less than 2% and in some cases slightly better performance, but within the margin of error of testing. All tests confirm that the specific performance impact to a deployed application is directly related to how this application is using system resources. Specifically, this means that in certain cases (e.g. a query)  a larger performance impact is possible.

While InterSystems has no evidence of significant performance degradations for customer applications, we strongly recommend that customers perform their own performance evaluation.

InterSystems continues to work with our OS, hypervisor, and processor partners on performance testing and further upgrades will be provided if/when necessary

+ 7   0 3
0

comments

535

views

+ 7

rating

InterSystems continuously monitors our systems for any evidence of attempts to exploit vulnerabilities such as the newly announced Meltdown and Spectre attack vectors.
 
At this time we have seen no indications of attempts to target InterSystems systems or technology using these vulnerabilities.
 
·         InterSystems is aware of recently reported cybersecurity vulnerabilities known as Meltdown and Spectre that affect a wide range of computer processors (See US-CERT Alert TA 18-004A, Meltdown and Spectre Side-Channel Vulnerability Guidance, https://www.us-cert.gov/ncas/alerts/TA18-004A).
·         As is the case with other technology companies, InterSystems is examining our products to assess and understand the direct impact of the vulnerability and what appropriate actions to take to remediate any discovered risk.
·         Same as with many other companies, I
+ 7   0 3
0

comments

834

views

+ 7

rating

Stable Releases of the Atelier plugin are now available from the Eclipse Marketplace. Just search for Atelier on the Eclipse website (https://marketplace.eclipse.org) or - even better - in the Eclipse IDE.

This is an convenient way to install this plugin, because you no longer have to enter the URL.

Last comment 15 January 2018
+ 6   0 4
585

views

+ 6

rating

Project related quality assurance efforts have revealed a number of concerns for the current release of 2017.1.0 and 2017.1.1 on all OpenVMS platforms. In certain situations, the impact can be severe. InterSystems will address these issues with the upcoming 2017.1.2 release, and in the meantime, will remove all 2017.1.x kits for OpenVMS from our Download Servers.
 
If you have immediate needs correcting existing deployments of this version, please contact the InterSystems WRC (support@intersystems.com).
 
+ 3   0 2
0

comments

371

views

+ 3

rating

With the recent release of Caché and Ensemble 2017.1, InterSystems customers can now create configurations where the data-at-rest cryptographic library used is compliant with FIPS 140-2.

Caché and Ensemble now provides you with the option to enable FIPS mode on RedHat 6.6, 7.1 on x86-64. This means is, that InterSystems products will no longer use the supplied crypto libraries that come with the kit, but will use the FIPS validated libraries provided by the Operating Systems vendor.

To configure your system, RedHat must operating in FIPS mode. This can be done be following the steps provided by RedHat. This process should also create symbolic links to the two libraries that will now be used: libssl.so.1.0.1e and libcrypto.so.1.0.1e.

In the /usr/lib64 directory:

            libssl.so should point to libssl.so.1.0.1e

            libcrypto.so should point to libcrypto.so.1.0.1

+ 2   0 1
0

comments

135

views

+ 2

rating

The last version of Caché, Ensemble released for VSI OpenVMS is 2017.1. Unlike HP OpenVMS (Alpha and Itanium), VSI OpenVMS on Itanium continues to be supported. This means that critical corrections or changes required to support customer’s hardware purchases will all be based on 2017.1 or earlier versions.

Related announcement: https://community.intersystems.com/post/platform-compatibility-hp-open-vms

0   0 2
0

comments

291

views

0

rating