Caché

During migration from Caché to IRIS I can preview a situation where some instance
have migrated to IRIS while others are still on Caché.
For various reasons this may be in place for some weeks or even months as the big bang isn't feasable.

So far I found a lot of statements related to mixed endinans,
but nothing related to cross operation beween IRIS and Caché.

?? any hints ??
?? any experience ??

 

 

Last answer 7 days ago Last comment 7 days ago
+ 5   0 3
79

views

+ 5

rating

I have SQLCompute with SQLComputeCode on a couple of Properties in my class.

These work fin when I insert/update via ObjectScript or SQL from the ManagementPortal.

However, if I insert (create new record) via my C# app using the Caché ODBC DLL the SQLCompute is ignored, it does not run.

Is this expected InterSystems Caché behaviour? We are on latest IRIS platform.

Last answer 5 days ago Last comment 4 days ago
0   0 2
57

views

0

rating

does Health Connect have an out of box setting to send some type of "Keep Alive" packet?  This is for a TCP connection.  I have a vendor that will disconnect from the engine if there is a 2 hour idle time.  would like to send something across every hour (if its idle) to prevent the disconnection.   I'm assuming this may be something custom that needs to be created, but thought I asked the community first.

0   0 2
0

comments

55

views

0

rating

Hi everyone,

I've encountered this annoying issue so many times before, if any one also encounter this issue, please share here if you have any solution.

So, I've been working on a web service project using HealthShare 2015. Sometimes I have to set a debug target to a csp file to debug it. If I pause the debug process about 3 minutes above or so (to examine an object, variable, etc..) the studio will hang.

0   0 3
0

comments

43

views

0

rating

My project need to  restore the previous part of the log,  and I use the rountine "^JRNRESTO" and filter.  After recovery completed,  the table structure is restored, but the table data is not restored, also unable to insert data into the table.

The filter is defined as follows:

Last answer 4 days ago Last comment 3 days ago
0   0 3
42

views

0

rating

Pretty straight forward.

I'm tempted to hard-code ISO-8859-1 inside my VSCode extension when working with CSP because this seems to be the encoding used by default, but I need to know if there's any other possible configuration. So can you share your experience when working with CSPs? Like issues with encoding, discoveries regarding it, workarounds etc.

Also, can someone tell me if it's possible to work with UTF-8 encoded CSP files using Atelier without breaking the encoding of the output file?

Last answer 5 days ago Last comment 4 days ago
0   0 1
38

views

0

rating

When using $SYSTEM.Status.DecomposeStatus(tSC, .tErrorList) in ObjectScript to get the lsit of errors (I need to do this so that I can generate a custom JSON with the error messages) what is the type of tErrorList returned and how to intialize?

Last answer 3 days ago
0   0 2
0

comments

22

views

0

rating