Caché

Syndicate content 126 

I created a Zen page with a header. All is good. I then created a new Zen page and during the wizard specified that it was a "subclass of a template page". So now I have Class Custom.App.HomePage Extends Custom.App.TemplateMaster. If I visit HomePage.cls I see the header from the template. However, the HomePage class has no XData Contents section so I have no idea how to actually add content. I tried adding the section but once I do then I don't see the template content anymore.

Last comment 14 January 2016
0   0 3
0

answers

127

views

0

rating

I have a tablepane in my Zen page that is tied to a class query.  When the page first loads, the table is empty.  A button onclick event causes the tablepane query to execute and load query results into the table.  I want an onchange event from a datalistbox to clear the tablepane so that it looks empty as it was when the page first loaded.  I have had no luck fiddling with javascript in the datalistbox's onchange.

Last comment 14 March 2016
0   0 2
0

answers

166

views

0

rating

I have a Powershell script to backup up a Cache database. The script runs through and backs up the database  with the normal 4 iterations. The script successfully produces the backup file and an associated log file. However, after completion of the backup there is what appears to be a permission error. I have not been able to find any information that would help me determine if this message impacts the integrity of the back up. From the end of the output of the backup:

Last comment 26 September 2017
0   0 2
0

answers

336

views

0

rating

When using the link component on a ZEN page the default behavior is for the link to appear to the right of the tablepane row. Has anybody changed this behavior so the link appears to the left of the tablepane row? Thank you in advance for any and all feedback.

0   0 1
0

answers

0

comments

82

views

0

rating

Hi,

I have been trying to implement SPA using routing between two components in a CSP page. 

If i use the line which i commented the page views and gets data from the vue instance (when not using the <route-view> and other 2 vue route functions below).

since i need to implement routing i am using as below, now the property "selectedYear" is not getting data from vue instane and i am getting the below error as well.

I dont know whether i am going down the right path.

please see my code below and help me

0   1 1
0

answers

0

comments

501

views

0

rating

In Cache for UNIX (Red Hat Enterprise Linux for x86-64) 2018.1.2 (Build 309U) Mon Mar 4 2019 15:07:46 EST

I have a master record that has a relationship to a table with multiple transactions, and the transaction table has a relationship to another transaction table with multiple other transactions.

IE Item to Physcal to Physical Report

Item Master:

Last comment 15 August 2019
0   0 3
0

answers

159

views

0

rating

[SOLVED]

added 

>/tmp/compilew.log &>/tmp/compilew.log ; tail /tmp/compilew.log

to redirect the output to the stdout. Somehow the javac has wierd behavior with the output on errors and verbose information.

Hi,

i want the JAVA-Projections and wrappers to compile after Caché created the files. The creation of the files works 100%.

My addition to createProjection in our Projectionclass is following:

Last comment 15 March 2016
0   0 2
0

answers

172

views

0

rating

How can I prevent large number truncation when using the DynamicObject and DynamicArray classes to create JSON in objectscript and then parsing the result in javascript. Are there any global settings that configure the output when using these classes?

 

I am looking at converting to the new DynamicObject and DynamicArray classes to build JSON. Our current (homegrown) JSON library forces string representation of numbers too long because of errors we were seeing with long numbers being truncated on the client, I am hoping to accomplish the same with the new classes.

 

Last comment 9 December 2016
0   0 3
0

answers

526

views

0

rating

I tried to access Caché using ADO.NET. This works fine but when I want to use Entity Framework, I can't access the Caché Data Source.

I'm using Visual Studio 2017, and followed the procedure described in Caché documentation.

(This document has been written  regarding VS2013)

Did some meet the same problem ?

Thanks in advance.

 

 

Last comment 21 March 2018
0   0 4
0

answers

363

views

0

rating

Application licensing enables InterSystems application partners to take advantage of Caché’s licensing capabilities for their own licensing purposes.

Caché manages customer application licenses just as it does Caché/Ensemble and InterSystems application licenses, maintaining usage counts and acquiring and returning user licenses as needed.

Application licenses consumed by a process or a CSP session are automatically released along with the Caché license consumed by the process or session when a process exits, halts or is deleted from the process table, or when a CSP session times out or is deleted.

More in docs.

Do you use this feature? If so, how?

I'm especially interested in license validation and general workflows?

0   0 1
0

answers

0

comments

131

views

0

rating

Hello all,

I have an XSL question and I wanted to see if someone within a community can help me out.  

To Summarize: I am working with XSL documents, single and multi-pages.  
Inside my style sheet XML document, which is supporting my pages, everything on the page, including a headers, footers and the items are calculated 
based on the portrait measurements. 
Pages come up on the screen as portrait, but sometimes, depending on dynamic data are wide, they do not print properly in portrait.

Last comment 2 February 2019
0   0 2
0

answers

99

views

0

rating

Hi,

I ran the Cache ODBC Driver installer as Administrator on my Windows 7 PC this morning. It completed successfully with o indication of any issues. When I check installed programs and features via Win 7 Control Panel, I see it listed as Intersystems ODBC Driver 1.00.000.

However, when I try to configure the driver via Control Panel - Administrative Tools - Data Sources (ODBC), I cannot find it. The only driver listed under the Drivers Tab is SQL Server.

 

I am not sure how to proceed.

 

I appreciate any suggestions.

Thanks,

Bill

Last comment 16 October 2018
0   0 3
0

answers

997

views

0

rating

Hi, 
I've organized my repository using TortoiseSVN. I was careful to use only svn commands while creating my file structure. Now all Subversion commands are working at the command line but not from within my IDE (Cache Studio). Basically I'm trying to write a plug-in for my IDE to use Subversion from within the Studio. Trying to integrate Subversion into my IDE, something like Subclipse, but for Cache Studio.  The error occurred after reorganizing my code into directories. For example at the command-line, svn info and svn status and all other commands work perfectly.  All Subversion commands work at the command prompt!

Last comment 10 March 2017
0   0 1
0

answers

633

views

0

rating

Hi Team,

               Our community is most useful for my learning. I have one concern.We need to add a chat box for discuss and interact with other developer in our community . It is most useful for maintaining the team relationship and sometime we get guidance from anyone on directly. I known already we have the chat box in global master(that chatbox just we send greetingsrelated messages only). This same one is need for our community also(All are reading articals and question on our community page).So I am asking chat box on our community page also.

Last comment 3 February 2019
0   0 1
0

answers

88

views

0

rating

Hello,

I had an issue when using the method Exists, I noticed that if you provide a directory for this method it returns 1.
This is really misleading, because sometimes the input could be a directory and the only way to predict this is to also test if the file is a directory.

I didn't tested using the Attributes method, but I supposed that this means could also be a solution for that issue.
But still, I expected the Exists method to return 1 for files and 0 for directories, since there's also method called DirectoryExists already.

Last comment 9 September 2019
0   0 1
0

answers

109

views

0

rating