Atelier

Syndicate content 80 

Hi

Has anyone managed to get a dark theme (Like Darcula or Obsidian) working on the Atelier plugin. The Eclipse themes apply to everything in the IDE except the editor window, so it kind of defeats the purpose. I've tried searching for one but so far no luck. I know you can set each colour individually in the settings but I'd like a single config I can load if possible.

 

Thanks

Last answer 28 February 2018 Last comment 28 February 2019
+ 1   0 7
684

views

+ 1

rating

​​​​​​​Hi, 

I've been going through the instructions at https://download.intersystems.com/download/atelier.csp  

Our development team are on the main hospital infrastructure so we need to whitelist any plugin repositories that Eclipse will need to get updates from.

I believe I need to whitelist the sites that host the both the Atelier and Eclipse plugin repositories:

Last answer 28 November 2018 Last comment 17 January 2019
0   0 2
165

views

0

rating

Hello experts, 

I am new to IRIS and I was told I could get a great hands-on experince with the commuity edition that is currently availabe on mutliple cloud providers.

Unfortunately connecting Atelier to the given IRIS instance has been unsuccessful: 

Accorording to this troubleshooting guide

Last answer 10 December 2018 Last comment 10 December 2018
0   0 2
169

views

0

rating

Hello,

I have a question about creating properties with curl.

I already did create properties in Java with the following command.

<DO db.%CreateProperty("TotalSteps","%Integer","$.TotalSteps")>

It created the property TotalSteps with the type %Integer and the data path $.TotalSteps (since the header of my data source is also TotalSteps).

Now I would like to create the same property in curl with the following command

Last answer 4 October 2018 Last comment 4 October 2018
0   0 0
123

views

0

rating

Hello,

Atelier 1.2 as well 1.3 throws java.lang.NullPointerException when opening a class file.

Never mind how to open the class file,  1) witin project explorer 2) atelier explorer 3) open resources  4) switcing between tabs (open files) etc..., I get these errors every time.

Never seen this problem in Atelier 1.1.

Do I miss something within the Eclipse environment? 

Does anyone has the same problem?

Best Regards,

Roger de Coninck.

Last answer 27 September 2018 Last comment 3 October 2018
0   0 2
345

views

0

rating

I have previously setup an Atelier project and it was running. I recently received the 1.3 release. Now, I am unable to click on the previously established connection to my Cache server (as seen in the Serve Explorer. I see the connection and the little arrow (implying that there is a hierarchy of items underneath). But, clicking that arrow opens nothing. Ultimately, I was trying to access files on the server so that I could add some new ones to my existing Atelier Project.

Last comment 2 October 2018
0   0 3
0

answers

137

views

0

rating

Hi,

Interested in testing the Eclipse / Atelier on my Mac with 10.13.6 High Sierra, I installed both and had a go at connecting to my Cache Server. It offers Address & Port and login ID and Password.

No matter what I gave it, it cannot connect, saying Server not found.

The Server is a virtual Server running Windows 12 Server on a dedicated IP address, to which I can connect correctly using Remote Desktop, I can Ping  the IP so all looks good, except Eclipse cannot find it.

Any hints would be appreciated.

Thanks,

Rosti.

Last answer 23 September 2018 Last comment 24 September 2018
0   0 3
223

views

0

rating

Hi All,

I'm practicing Atelier in Eclipse, but

While working CSP page.

      1. Create new Web Application 

      2.  Open CSP Web Application in Atelier Project 

      3. New CSP page -> Save

i'm getting below error Message.  

/testv1/test.csp was saved locally but could not be saved remotely.

ERROR #5912: Page '/testv1/test.csp' does not exist

test.csp is saved locally but could not be saved remotely.

Last answer 14 September 2018 Last comment 15 September 2018
+ 1   0 3
169

views

+ 1

rating

Hi

I'm starting work with the Atelier. 

Starting from the point that Eclipse uses local files on the workstation, COS development can be versioned with market tools (For example GIT or Subversion).

I would like to know how the community has worked with code versioning, to create a consistent versioning model.

I initially have the following doubts:

Last answer 13 September 2018
+ 5   0 2
0

comments

249

views

+ 5

rating

I am having trouble configuring the environment in eclipse have download eclipse  for java script and web developers  followed the video but could not connect to the server I have my Apache server 7.0 added to the java environment and I can start and stop the server through eclipse IDE but when I fire atelier and add server I get the above error any help please .This is the first time I am trying to use the plug in through eclipse .Just in case There is another installation I need to do please advice but I am guessing something to do with atelier not seeing my configurations or permissions

Last answer 10 August 2018 Last comment 13 August 2018
+ 1   0 4
180

views

+ 1

rating

Hello,every body. 

I am having a problem when using atelier. I found that the web front-end related files (such as csp, css, js, etc.) will change in format when they are synced to the server.

For example:

The original format of the js file may be UTF-8. However, when I edited and saved in atelier, the file version format on the server became ANSI. I tried to configure the environment in eclipse, but it doesn't seem to work.

E.g:

Last answer 7 August 2018 Last comment 8 August 2018
+ 1   2 2
191

views

+ 1

rating

When I try to compile through Atelier (Compile Project), I noticed that in compilation with error it returns this message 'Failed to read /api/atelier/v1/ ...':

No additional Atelier files to synchronize.
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck

Last comment 24 July 2018
+ 1   0 4
0

answers

286

views

+ 1

rating

Atelier is no longer working for me. I am getting the following error: Could not create the view: com.intersys.eclipse.ui.views.CacheExplorer.

Expanding the details available shows the following below. Has anyone seen this and know how to fix it? I uninstalled and reinstalled the Atelier plug-in but that did not help.

Last answer 20 July 2018
0   0 1
0

comments

174

views

0

rating

We have started playing around with Atelier, primarily to enable us to commit our existing Ensemble code within source control (GIT). 

It seems Atelier works well with classes and routines however is unable to directly export lookup tables and HL7 schemas. Can someone confirm/validate this is the case? if so, when will this functionality be made available as it's absence is a deal breaker for us?

Last comment 15 July 2018
0   0 2
0

answers

232

views

0

rating

My Atelier workspace used to maintain my settings, open files, window configuration, etc. when I would shutdown Eclipse and open it again later on my MacBook Pro. However, since I have upgraded to the latest version of Atelier 1.2.119 that no longer happens. I now have to open my last used files and reconfigure my windows the way I like them every time I start Eclipse/Atelier. 

Anyone else have this issue? I have tried many things from Google searches to fix this but nothing has worked.

Last answer 6 July 2018 Last comment 12 July 2018
0   1 2
192

views

0

rating

Atelier is not translating the indentation spaces used to format XDATA sections in Cache Studio. Lack of these spaces makes the XDATA difficult to read. The styling (coloring) of the code is working just fine. Also, it appears that other class code indentation works fine.

Is anyone else seeing this issue? Has there been any discussion when this issue might be addressed by InterSystems? How shall I get some attention to this issue?

Last answer 10 July 2018 Last comment 10 July 2018
0   0 3
143

views

0

rating

When trying to do an Atelier search, the scope section shows a little red 'X' next to the server dropdown box. Hovering over it shows a message stating that "the server does not support Atelier search."

What version of Cache is needed to allow for Atelier searching?

Last answer 9 July 2018 Last comment 9 July 2018
0   0 3
100

views

0

rating

Often, the first time I start up Eclipse (Atelier plug-in), all of my local classes indicate "warning" as if they are out-of-sync. When I  try to synchronize, I get the following error:

Synchronization failed: [server is broken] java.lang.ClassNotFoundException: Provider org.glassfish.jersey.internal.RuntimeDelegateImpl could not be instantiated: java.lang.IllegalStateException: No generator was provided and there is no default generator registered

Last comment 5 July 2018
0   0 5
0

answers

298

views

0

rating

Hi,

When i try to configure my server connection in Atelier (Eclipse), i am getting the below exception.

java.lang.ClassNotFoundException: Provider org.glassfish.jersey.internal.RuntimeDelegateImpl could not be instantiated: java.lang.IllegalStateException: No generator was provided and there is no default generator registered

It was all working fine and i think that the only thing which i have done was installing some windows updates. Now when i try to configure the server configuration i started getting the above error, any suggestions to fix this?

Thanks,

Last answer 10 June 2018 Last comment 5 July 2018
0   1 2
224

views

0

rating