Atelier

Syndicate content 80 

Version: 1.0.123

Cache for UNIX (Apple Mac OS X for x86-64) 2016.2 (Build 619U) Thu Mar 17 2016

After deleting a class on the server, Atelier still wants to believe it exists.  I even deleted the project and the server.  After re-creating them, it still believes the class exists.  I log in with studio and it shows the class has been removed.

If I attempt to open the class in the server explorer, I get a null pointer exception, but I can open any other class.

Any thoughts would be appreciated.

James

Last answer 21 March 2016
+ 1   0 1
0

comments

186

views

+ 1

rating

Some thins I have noticed, which I am not sure are bugs or features to come.

1.) Go to type declaration (F3 or ctrl+click on a class/variable/method)

It doesn not work on object variables and methods

Where it does work, it opens the related class but it is not editable.

 

2. )There is no code indentation correction/ctrl+L ?

Is this planned?

I would very much prefer to have formatting  even if it means loosing some COS "functionalty".

 

 

 

Last comment 14 March 2016
+ 1   0 6
0

answers

127

views

+ 1

rating

Hello! 

I'm trying to make a simple hello world program for iKnow but the documentation only shows examples using the scripting language or XML XData. 

The domain is already created and configured, what I hope for is to be able to work with the data in some high-level language. 

Is it possible to do something like this:

 


int domainId = 1;
IKnow iknow = new IKnow( domainId );
List concepts = iknow.getTopConcepts();

Any feedback will be greatly appreciated!

Last comment 3 March 2016
+ 1   0 4
0

answers

294

views

+ 1

rating

I am trying out Atelier.  I have installed it and managed to get it to connect to a cache instance to test it.  I have created a local project and I am trying to copy the server files to it using the "Copy to Project" item on the popup menus.  I can copy both classes and routines to the project without issue, but when I try to copy the CSP files, I get the following message:

com.intersystems.atelier.utils.CheckedExceptionWrapper: Input length = 1

Last answer 27 August 2019 Last comment 9 August 2019
0   0 2
69

views

0

rating

Hi All,

I've got Eclipse installed (Javascript 2019-6) but when search for Atelier from the market place within the IDE it does not show up.

I found it in the browser version of the marketplace, and tried to drag it in but got the message 'The following solutions are not compatible with this version of Eclipse'.

I tried installing an older version of Eclipse (photon) but the installer keeps telling me I haven't got JRE 1.7+ installed (I have 1.8 64bit installed already), and sends me to a download page so I can't continue.

Last answer 8 July 2019 Last comment 9 July 2019
0   0 2
102

views

0

rating

Hi,

recentley we started to work with Atelier & VSTS in our organization .

we are looking for a way to use the VSTS as Our Version/Source control system .

I have read the article about "Continuous Delivery of your InterSystems solution using GitLab" & now trying to find a way to use a similar metodology with the VSTS that we have in our organization.

Last answer 21 May 2019 Last comment 21 May 2019
0   0 3
186

views

0

rating

When I tried to make change in DTL view then only i see following error whereas in XML mode no issue in compilation.

Any resolution and solution ? it looks like some missing xml parser configuration or Pulg ins ?

ensEPC.DataTransforms.dtEcgCEpc081518.dtl was saved locally but could not be saved remotely.

ERROR <Ens>ErrInvalidDTL: Invalid DTL

ERROR #5001: attribute 'sourceclass' is not declared for element 'transform'

ERROR #5001: attribute 'sourcedoctype' is not declared for element 'transform'

Last answer 22 April 2019
0   0 1
0

comments

59

views

0

rating

Hello everyone,

 

I'm trying to migrate the IDE for programming in COS, we normally use the Studio, but we want to use a more modern IDE. Our team has knowledge with Visual Studio plataform, but we couldn't configurate the compiler and terminal, I installed the extension InterSystems ObjectScript and tried to configurate to connect with my local machine, unfortunately the connection don't sucessed.

Someone has material for how i can connect and compile? Some material i saw show how to use the compiler, but not how can i do the configuration.

 

Last answer 3 April 2019 Last comment 8 April 2019
0   0 3
302

views

0

rating

Hello Gentlemen,

 

My Business process connector receive a Oru_01 hl7 message with an ED segment inside (Base64 pdf). How is it possible to extract it and create a pdf file within?

Here is the sample of function I have. I know it doesn't work but if you could help me, it would be perfect. Here is my function, the goal would be it create the file where I want and return me the link of the file.

Last answer 7 March 2019 Last comment 7 March 2019
0   0 3
245

views

0

rating

Hi,

I am having a problem in REST service when de-serializing JSON using a nested Property.

I am new to Intersystems and my first time creating REST Service. I setup Atelier dev environment. The worst IDE I have ever worked in. I was able to  attach to a process in the debug perspective and step through the code, but one cannot see contents of variables nor print anything to the console, so it is useless as a debugging tool. When looking at a variable all it displays is its type of the variable and if I try to "watch" I get:

Last answer 24 February 2019 Last comment 25 February 2019
0   0 2
148

views

0

rating

Hello everyone,

I'm using Atelier 1.3. When we configure a server and use HTTP to connect, works fine. But when we activate the Secure connection option I get the Unregonized SSL message, plaintext connection?

Do I need to perform any configuration on my server so that Atelier can access a secure connection?

Last answer 2 January 2019 Last comment 7 February 2019
0   1 4
194

views

0

rating

When I  open a BPL, or DTL class in Atelier it attempts to open a graphical editor using Internet explorer.

Even though I have IE 11 installed it is somehow "stuck" in IE 7 emulation mode when invoked from Atelier (Eclipse).

So I get an error message, and cannot use the graphical editor.  This has been true in the Marketplace Atelier 1.3 and also Beta.

I'm running Atelier IDE Beta 1.3.141, on Eclipse Javascript 2018-12-R.

Two questions:

Why cannot the editor work with IE7 anyway?

How can I get Atelier to invoke IE with the right options?

Last answer 30 January 2019 Last comment 28 January 2019
0   0 1
124

views

0

rating

Let Say I have 
Class Carrier Extends %Persistent

Property Employee As Array of Class Employees

Class Employees Extends %SerialObject

Property Name As %String

Property Address As Array of Class AddressDetail

Class AddressDetail Extends %SerialObject

Property Street1 As %String

Property Street2 As %String


I can get value for Employee Name  as Employee_Name.

But I want to Get Value of Address Street1 and Street2 of Class AddressDetail using SQL Query
How can I get that?

Last answer 18 January 2019 Last comment 25 January 2019
0   0 2
166

views

0

rating

​​​​​​​Hi, 

I've been going through the instructions at https://download.intersystems.com/download/atelier.csp  

Our development team are on the main hospital infrastructure so we need to whitelist any plugin repositories that Eclipse will need to get updates from.

I believe I need to whitelist the sites that host the both the Atelier and Eclipse plugin repositories:

Last answer 28 November 2018 Last comment 17 January 2019
0   0 2
151

views

0

rating

Hello experts, 

I am new to IRIS and I was told I could get a great hands-on experince with the commuity edition that is currently availabe on mutliple cloud providers.

Unfortunately connecting Atelier to the given IRIS instance has been unsuccessful: 

Accorording to this troubleshooting guide

Last answer 10 December 2018 Last comment 10 December 2018
0   0 2
152

views

0

rating