API

Syndicate content 12 

I am experiencing a problem with an EDI process that uses a SQL Batch Service to connect to our DEV environment.  However, when we point the EDI service to our TEST server, it errors out.

I have checked every single property on our TEST and DEV servers as well as the properties on the associated tables.  They are identical.  Nothing has changed in the SQL either. 

0   0 1
0

answers

0

comments

18

views

0

rating

Good morning -

I am attempting to pass some HL7 content (say, a complete ADT message) from one server to another via REST/JSON - for reasons. 

I can get the data across but when I try to create an EnsLib.HL7.Message object from the message in the JSON body, I end up with just the start of an HL7 msg in the resulting object. Looks like: MSH|^~\&

The start of the code accepting the data looks like this:

Last answer 30 September 2019 Last comment 30 September 2019
0   0 2
69

views

0

rating

I am trying to return a stream soap response using web services I can call my web service supply it with a xml string which works fine . I then work on that XML and try to return  a Stream but all works in the production when my service receives the stream after I get the error  as if its trying to copy stream to a variable and I am confused as to where that operation happens.

Last comment 23 September 2019
0   0 1
0

answers

69

views

0

rating

Hi folks,

I started to play with docker and InterSystems products, it's amazing, but I got the error when try to load the IAM-0.34-1-1.tar.gz image to docker:


[root@CONF-RHEL-DOCKER-IRIS-API admconf]# docker load -i IAM-0.34-1-1.tar.gz
open /var/lib/docker/tmp/docker-import-547148651/IAM/json: no such file or directory

Bellow docker and docker-compose version:

[root@CONF-RHEL-DOCKER-IRIS-API admconf]# docker --version
Docker version 19.03.2, build 6a30dfc

Last answer 18 September 2019 Last comment 20 September 2019
0   0 2
55

views

0

rating

Good Afternoon,

I'm working on a API documentation that wil be interactive, it's based on a BS class on Ensemble.

The objective on making the documentation is simplify the undestanding of the operation for those who are not acquainted with the Ensemble environment.

My problem is, when using Postman to test a operation the indentation appears as such:

Last answer 6 August 2019 Last comment 6 August 2019
0   0 1
125

views

0

rating

Hi There ,

     We are trying to do a small POC trying to integrate NHS Careconnect with Ensemble/Healthconnect. Does anyone have implemented this before. It would be good that you provide some suggestions  or any sample implementation. It would be good to get suggestions any  interesting use cases 

within NHS England for the POC.

Last answer 24 April 2019 Last comment 1 May 2019
0   0 2
116

views

0

rating

Hi I'm using ensemble/cache 2016 is a NTML auth possible. Any code examples?

Currently I've got

set hr3 = ##class(%Net.HttpRequest).%New()
set hr3.Username = "xxxxxx/xxxxxxxxx" 
set hr3.Password = "xxxxxxx"
do hr3.Get("http://xxxxxxxxx/CaseNoteTracking/api/CaseNoteTrackingAPI/Get")

From the looks of things I need a http 1.1 request?

Last answer 23 January 2019 Last comment 28 January 2019
0   0 3
208

views

0

rating