Announcements

I am trying to fetch the data from cache database. But i got the error like "CSP application closed the connection before sending a responce".

Below is the query.

SELECT
CallbackComment
FROM SQ.CBPhoneResult_View Where PhoneDateODBC = '2018-04-09'

I have investigated and found that "CallbackComment" contains the special character single quotes " ' "  for one result and due to this i got this error.

In this field data is enter by customer. so we cannot restrict them like Do Not use single quotes.

Last answer 7 July 2018 Last comment 9 July 2018
0   0 2
507

views

0

rating

Good morning,

Background to task: Shut down Ensemble from a task in Task Manager.

I have a batch file that shuts down Ensemble when run as administrator. I can confirm this works, as it brings up the shutdown/restart prompt for Ensemble, however I now need to plug this into Ensemble's Task Scheduler so it can be run on-demand.

At present I am trying to use: do ^execute: %windir%\system32\cmd.exe Z:\Scripts\shutdown.lnk

Last answer 29 November 2018 Last comment 29 November 2018
0   0 5
382

views

0

rating

Cache 2016.2.1.603 for windows)

I created a few classes and one class called jitPod.Api.toServer.additionalConsignments and realised even before I did any work,, that the word "Api" (note capital A) needed to be "api" (all lowercase)

it would not allow copying the class to the lowercase name because the directory already exists (i understand that)

so I exported the class to an XML, edited the xml to become lowercase "api" , deleted all the classes (and directory name) and re-imported the class.

Last answer 13 March 2018 Last comment 16 March 2018
0   0 6
344

views

0

rating

Hi,

I am sending a request message to Business Process which has one property as Dynamic Object type. So i get the JSON in my REST service and convert that as a dynamic object and set that in the request message and calling the business process from the business service. But the request is not getting sent to the Business Process. Is it possible to send dynamic object input to the business process.

Last answer 15 May 2018 Last comment 1 days ago
0   0 3
315

views

0

rating

I am trying to determine the write-access to a windows-directory, using the method %File.Writeable(). But, this method always returns the boolean "true", even when I have revoked the write-access of Healthshare-user in this directory.

Note:
1) When the same ensemble-service tries to write a file in this directory (which it says is "writeable"), it fails.
2) The method %File.Writeable(...) works perfectly in the case of files.

Any help is appreciated.
Thanks in advance... :-)

Last answer 6 February 2018 Last comment 8 February 2018
+ 1   0 3
297

views

+ 1

rating

We are going to start using Git within Cache.

One question came up - if the branch that you checked out does not have the class or mac file, what is the correct thing to do?

Should we delete from Cache or should we just keep it?

I'm leaning more towards deleting it because Cache should reflect what is in your work folder in git. But other team members are saying to keep it.

Last answer 20 April 2018 Last comment 20 April 2018
0   0 4
261

views

0

rating

Hey guys,
I need your help.

I am writing a code in Python and I want to create a database and some properties and then to send json files (data) to this database. (I use client-server-model for loading the data into IRIS)

I use curl methods and convert it in Python code with:

curl.trillworks.com/#python

My code so far:
 

Last answer 7 September 2018 Last comment 10 September 2018
0   0 3
166

views

0

rating

On one HealthShare servers (RH Linux, 2017.1.1), I am not able to login to Studio for this server. When I select the server connection from the notification tray icon, choosing Remote System Access, Studio, then the server, the error I getting is:

Unable to log on to server {Server Name}

Communication link failure

I've tried using both DNS name and IP address, same result. Using Atelier, I am able to connect to the server using the same DNS name and Web Server Port that I'm trying in Studio.

Last answer 29 June 2018 Last comment 1 July 2018
0   0 4
490

views

0

rating

Hi

We are experimenting with maintaining my image files outside of Cache as it will scale out pretty soon and obviously as its not Object based.

For this purpose we have decided to go with AWS S3 File Storage

Now S3 does support REST Operations and Ensemble does it too

However I am not able to find any example in Intersystems Documentation which demonstrates any Put Operation

Only documentation I could find is this explaining the GET operation

Last answer 27 July 2018 Last comment 27 September 2018
0   0 4
1308

views

0

rating

Hello guys,

I have been playing around with the deployment tools from Ensemble (mostly based on this article https://docs.intersystems.com/latest/csp/docbook/DocBook.UI.Page.cls?KEY...) , but so far the one thing I still couldn't figure out is how to group files into a single "Studio project file".

By using the deployment tool UI, supposing that I want to add a bunch of custom files to my deployment file (XML), it's practically impossible because I need to add one by one.

Last answer 17 July 2018 Last comment 18 July 2018
0   0 4
252

views

0

rating

most of my jSON data is single words, but when it comes to sending chunks of a memo/email via JSON, that totally different

which is the correct conversion process to prepare data ready to insert into the data part of a JSON string so that all problem characters are converted

JSON of course crashes if you use the wrong format of quotes (single or double) and you ned up having to use &QUOT and \' to get around that but is there a simple call to something that will just take care of preparing the data from the JSON string both on the inward and outward part of JSON

Last answer 16 March 2018 Last comment 17 March 2018
0   0 3
235

views

0

rating

When using the JSON_OBJECT() function in Caché SQL on a %String property that contains JSON syntax, it converts the %String into a JSON object instead of escaping it as a string literal. How can I prevent this? (without ridiculous hacks like "add a space to the beginning of the value" as we don't always know which properties will contain these values and I certainly don't want to have to check for nulls and add/remove a space every single place this value is used in the application)

I don't want these strings automatically marshalled into JSON objects.

For example:

Last answer 20 November 2018 Last comment 28 November 2018
0   0 3
283

views

0

rating

I  have generated a class using the linked procedure wizard however  I can't get it to work if the  datatype  of one of the parameters is VARCHAR(MAX).  It works fine if I change it to say VARCHAR(500) and  rerun the  stored procedure wizard. 

I get the following  error returned.:

ErrorMsg:   SQLState: (07002) NativeError: [0] Message: [Microsoft][ODBC SQL Server Driver]COUNT field incorrect or syntax error

Last answer 10 May 2018 Last comment 1 June 2018
0   0 4
377

views

0

rating

I have a service that takes a file and pass it through to the production .While I am passing the file through I get the file stream and set it to a variable within my message and the variable is of type %Ens.StreamContainer. But after all processing and I need to write out my file to a pdf format The file gets written but is a corrupt file since I can not read it I have tried this with asimple pass through everything is fine .But here I do not know what I am doing wrong here is the operation code

Last answer 22 June 2018 Last comment 29 June 2018
0   0 4
292

views

0

rating

I just downloaded and installed the latest WebTerminal into my local copy of Healthshare 2016.2.1

I installed via studio and everything compiled without error.

However when I run it I just see a black screen. The help window at the bottom of the screen pops open when I type '/' but I just can't get any response.

Any suggestions as to how to trouble shoot this?

Mike

Last answer 15 October 2018 Last comment 19 October 2018
0   0 3
176

views

0

rating

Hi

Has anyone managed to get a dark theme (Like Darcula or Obsidian) working on the Atelier plugin. The Eclipse themes apply to everything in the IDE except the editor window, so it kind of defeats the purpose. I've tried searching for one but so far no luck. I know you can set each colour individually in the settings but I'd like a single config I can load if possible.

 

Thanks

Last answer 28 February 2018 Last comment 28 February 2019
+ 1   0 7
638

views

+ 1

rating