Announcements

I followed the Documentation instructions to install Caché on my Linux box and it seems to be running fine except when I try to modify the configuration.  I keep getting errors that a previous cache.cpf file (e.g., cache.cpf_8503) cannot be opened.  Is my Linux "user who owns instance" account deficient in Linux permissions?

Last answer 22 April 2016
0   0 1
0

comments

145

views

0

rating

Good afternoon, I have image files stored on disk. I would like to display those images in an <image> control as the end user clicks on rows in a tablepane. I already do this with image data stored in a cache database:

s imageComp = %page.%GetComponentById("ImgTab"_tLdCnt)
s imageComp.disabled=0
s tId=rsId.Get("ID")
s tPageObj=##class(My.PageObj).%OpenId(tId)
s oid=tPageObj.ImageBLOB.%Oid()
s encryptedOid=..Encrypt(oid)
s imageComp.src="%25CSP.StreamServer.cls?STREAMOID="_encryptedOid

 

Last answer 21 April 2016 Last comment 22 April 2016
0   0 2
379

views

0

rating

Is is possible in Atelier to open a macro declaration?  Using the context menu results in a "Current text selection does not resolve to a Script element" error in the status area at bottom of window.

Also the arguments for the macro are not shown on hover.

Doesn't seem to matter if the associated include file is added to the project.

(Version: 1.0.142, Mac OS X)

Last answer 22 April 2016
+ 1   0 1
0

comments

213

views

+ 1

rating

It looks like the normal usage of calling an Ensemble based Web Service via Ensemble is to create an Ensemble Business service that inherits from EnsLib.SOAP.Service which is then used to call a business operation which inherits from EnsLib.SOAP.Operation and the SOAP Outbound Adapter which can be generated via the SOAP wizard.

Last answer 21 April 2016
0   0 1
0

comments

370

views

0

rating

I tried logging into https://beta.learning.intersystems.com to view a video.  My browser auto filled the login form.  The username, the same one I use here and on many other ISC sites, is "sbeeson_MHCX".  Now I have a message that says "Only lowercase letters allowed" and any time I visit the login form it just shows the same message.  I cannot get back to the form.

I could obviously use an incognito window or clear my cache, but this needs to be fixed.

Last answer 21 April 2016 Last comment 21 April 2016
0   0 2
318

views

0

rating

Hello,

 

In my project, I am calling a store proc on third party database. I am using SQL Gateway and ODBC. Everything is working fine until the store proc changed.  In store proc they have changed the return alias name for a column. In Ensemble Snapshot I am not seeing the modified alias name until I restarted the whole Healthshare instance.

 

Here is my question, is there any other way? We do not want  to take the instance down if it happens after we go live.

 

Thanks

Raghu

Last answer 21 April 2016
0   0 1
0

comments

325

views

0

rating

Hello,

For CachéQuality I'd love to be able to create issues when the programmer uses classes which are deprecated for this or that version of Caché... But short of reading all the changelogs of all versions, I can't really tell when a command appeared (for instance RETURN; I know now that it appeared in 2014.x, but it took me some time to realize that), or when a (set of) class(es) became deprecated (for instance %GlobalCharacterStream to be replaced with %Stream.GlobalCharacter -- I don't even know since which version this is true :/).

Last answer 18 April 2016
+ 2   0 1
0

comments

177

views

+ 2

rating

Hi,

IHAC who is trying to connect Ensemble to Quadramed for HL7 messaging, however, it seems that in order to do this, the following is required:

"we open a passive connection to Quadramed and then listen for a connection request from Quadramed, once this is established we then send messages"

 

Has anyone done this before?  Is this possible with the standard HL7 components?

 

Thanks,

Steve.

Last answer 14 April 2016
0   0 1
0

comments

204

views

0

rating

Hi everyone!

I have imported a schema (HL7 v2.5 XML schema) using the "Ensemble > Interoperate > XML" and I have built a Web Service that receives a string with an XML document that follows the schema. I have used EnsLib.EDI.XML.Document as follows to consume the string and produce the XML vDoc:

Last answer 9 April 2016
0   0 2
0

comments

370

views

0

rating

Hi all,

I've been looking for a way to extract the sorting  from the ^CacheTemp.zenData global that contain the tablePane snapshot data in order to use it on a report following the current UI sorting criteria.

I could see that if the column is sorted by one column, new entries with this structure are created:

^CacheTemp.zenData(<sessionId>,<snapShotId>,<tablePaneId>,"index",<columnId>,<value>,<dataId>)=""

Last answer 1 April 2016 Last comment 1 April 2016
0   0 3
300

views

0

rating

Hi Community: I have a legacy Caché based app that has Zlogin or %Zlogin routine. I understand that such routine will be invoked as soon as the user logs in. Can someone tell me where to find such routine? The namespace where the user connects to? Or in CACHESYS? Thanks, HT

Last answer 26 March 2016
0   0 1
0

comments

178

views

0

rating

In Atelier when resolving conflicts with the server the screen shows the Local copy and Server copy and the differences, but depending on where the difference is you cannot tell what what the document is, you need to scroll to the top to see what it is before deciding what to do.  It should indicate the class or routine name beside "Conflicting Server documents"

Last answer 24 March 2016
+ 2   0 2
0

comments

112

views

+ 2

rating

Please consider these two concepts:

Concept 1 - Web Service or Web Application or Server Side

Concept 2 - Client Service or Client Application or Client Side

Maybe I am just a Web/Zen newbie, if I am and you all understand this, I apologize. (no nasty remarks please)

The questions are numbered, if you wish to respond to an individual question please precede it by the question number.

  1. Is there consistency in naming these concepts?

 

Last answer 22 March 2016
0   0 1
0

comments

259

views

0

rating

Version: 1.0.123

Cache for UNIX (Apple Mac OS X for x86-64) 2016.2 (Build 619U) Thu Mar 17 2016

After deleting a class on the server, Atelier still wants to believe it exists.  I even deleted the project and the server.  After re-creating them, it still believes the class exists.  I log in with studio and it shows the class has been removed.

If I attempt to open the class in the server explorer, I get a null pointer exception, but I can open any other class.

Any thoughts would be appreciated.

James

Last answer 21 March 2016
+ 1   0 1
0

comments

179

views

+ 1

rating

I am trying to debug a class on Atelier and it is not stopping at the defined breakpoint.

Atelier IDE Version: 1.0.107 - Cloud Connection

I have already taken a look at the Community´s Atelier Debugging Video and followed the steps without success.

Can anybody help me on that?

Tks. 

Last answer 18 March 2016 Last comment 18 March 2016
+ 2   0 0
249

views

+ 2

rating